Sign in to follow this  
Followers 0

Can't Get Rid Of Flickering Noise In Reflection

28 posts in this topic

Posted

This is an example of a reflection pass. In the circled areas, you'll see the dotted reflections. These aren't supposed to be there, and flicker when animated. This is just a straight reflection. No GI, AO, or even any textures.

I need to get rid of this stuff, ASAP. Can someone please help?

Thanks.

post-43534-1219353607_thumb.jpg

Share this post


Link to post
Share on other sites

Posted

Just a guess, But do you have Anti Alias on

Share this post


Link to post
Share on other sites

Posted

Yes. I have altered every single setting, one direction, then the next, to see if it would help. Nothing.

Share this post


Link to post
Share on other sites

Posted

Have you tried to increase the Antialiasing minimum setting to 2x2?

Share this post


Link to post
Share on other sites

Posted

Yes. Tried a whole variety of options for max and min. No improvements.

Further info. The model is a clean active extrude nurbs piece. So I don't think that would be part of the problem. I've noticed this kind of poor rendering ability since I started using C4D. This is hardly the first time that I've seen this kind of thing.

Share this post


Link to post
Share on other sites

Posted

try increasing the "Ray Depth" in "Render Settings/Options"

Share this post


Link to post
Share on other sites

Posted

Amped up both ray and reflection depth. No help. Ugh!

I'd post the file, but it's the client's logo, and I can't give that model out.

Share this post


Link to post
Share on other sites

Posted

Whats the phong angle set to?

Share this post


Link to post
Share on other sites

Posted

Everything between 0 and 180, along with totally off. I just doesn't make any difference.

Share this post


Link to post
Share on other sites

Posted

could you post the scene file?

Share this post


Link to post
Share on other sites

Posted

Like I had previously mentioned, it's a client's logo, so I can't share the entire file. But I'll delete what's not needed, and post that file tomorrow, first thing.

Cheers!

Share this post


Link to post
Share on other sites

Posted

i didnt read that post smile.gif

Share this post


Link to post
Share on other sites

Posted

Sorry. Didn't mean to sound snippy.

Share this post


Link to post
Share on other sites

Posted (edited)

Whats the scene size in relation to the grid.

I noticed the if the object is 100 time larger then the entire viewport grid itself the render and view in the port will be messy.

Scaling the scene down alittle will help if thats the problem.

Just another guess......

Edited by mrkucz

Share this post


Link to post
Share on other sites

Posted

Have at it boys and girls. I hope someone can crack this nut.

Thanks!

reflection_flicker_problem.zip

Share this post


Link to post
Share on other sites

Posted

Anyone have a chance to take a look at the project? Just curious if there are any ideas out there.

Thanks.

Share this post


Link to post
Share on other sites

Posted

It's just an AA problem. Set the Min/Max Level to 4X4 and 8X8 (or 8X8 and 16X16 if you can spare the render time) and it's fine.

Cheers

Karl

Share this post


Link to post
Share on other sites

Posted

Thanks Karl. I just happened to try that, and found some improvement. I had previously only adjusted the min, but the max has to come up, as you said. This is an unfortunately thing. The render times are likely to really add up, and this seems to be an issue with reflections, as I haven't noticed such artifacts with diffuse or specular channels.

Share this post


Link to post
Share on other sites

Posted

This is an odd one - not sure why the AA requirements of your scene are so high but raising the Min/Max certainly seems to do the trick. Don't know how complicated the full scene is (I assume that was just the part you could show) but the render hit wasn't catastrophic when I tested the scene. Depends on your machine I guess - I'm on an 8-core Mac Pro. This kind of thing is such a pain, seems like such a diversion when you just want to get on with it.

Cheers

Karl

Share this post


Link to post
Share on other sites

Posted

Using a quad intel mac, so speed is decent. But yes, the real scene is substantially more complicated. The real bugger is that the artifacts just seem so arbitrary. Other aspects of the same scene look perfect, even with the AA turned WAY back.

Totally agree about the pain. But, I've been having to solve problems on the fly (like we all do) for years. It's just part of the process, and I guess if this stuff were easy, I wouldn't get paid to do what I do!

Share this post


Link to post
Share on other sites

Posted

You could use a Compositing Tag on the troublesome elements and force the AA just for those elements. Might help with the render times.

Cheers

Karl

Share this post


Link to post
Share on other sites

Posted

That sounds intriguing. Can you elaborate? I don't think there are AA controls within the compositing tag. Do you just mean to run off some object buffer passes?

Share this post


Link to post
Share on other sites

Posted (edited)

OK, I've never used this myself so I'm no expert but there are AA settings in the Compositing Tag under a check box called Force Antialiasing and then you have the same settings as in the AA tab proper. I assume that this Compositing AA setting allows you to set the AA however you want it for the individual object that the tag is attached to and independent of the main AA settings. This would mean that you could push the AA up just for the problem items and so keep your render hit to a minimum. Check the documentation, or maybe someone else can put me straight on this if I've got it wrong.

Cheers

Karl

Edited by Lesia44

Share this post


Link to post
Share on other sites

Posted

as far as i know that exactly what it does, can be your best friend at times!

Share this post


Link to post
Share on other sites

Posted

I've never even noticed that. I'll definitely check that out, thanks.

Share this post


Link to post
Share on other sites
This topic is now closed to further replies.
Sign in to follow this  
Followers 0