Sign in to follow this  
Followers 0

Dynamics Problem, Objects Falling Through Ground Plane

10 posts in this topic

#1   Posted

really simple scene. A sphere, high up, that falls onto a cube that is sitting on a ground plane. As soon as the simulation starts the cube that is resting on the ground plane starts sinking through the ground plane. The sphere falls, hits it normally, then bounces on the ground plane, this is good, the sinking cube is not..

settings are:

Ground plane mass: 0, collision detection: Full

Cube mass: 5, collision detection: Full

Sphere mass: 3, collision detection: Full

Any hints / pointers?

thanks in advance

Share this post


Link to post
Share on other sites

#2   Posted

Hi and welcome to the cafe welcome.gif

Please will you update your profile with the modules you have so that you will get more precise help.

I don't have the dynamics module myself so I cant offer any help.

Someone here might be able to give you some pointers.

Thanks

Steve

Share this post


Link to post
Share on other sites

#3   Posted

We need to see a scene file. Could be your objects don't have enough segments.

Please up date your profile. You are asking a question about dynamics yet your profile list no modules.

3DKiwi

Share this post


Link to post
Share on other sites

#4   Posted

Are all the objects make editable?

dito upload the scenefile.

Sal

Share this post


Link to post
Share on other sites

#5   Posted

Thanks all, updated my profile, and email notification parameters... I've attached a project, you can see the cube just kinda sinks through my ground plane... I tried upping the cube segments, but to no avail... as you can see I'm new at this.. thanks for the welcome too!

naughtyCube.c4d

Share this post


Link to post
Share on other sites

#6   Posted

Thanks. Downloaded it. I'm afraid there's not much you can do about this. C4D's Dynamics module is way out of date and needs dumping in favour of a completely rewritten version.

For something like this I would manually animate the objects.

3DKiwi

Share this post


Link to post
Share on other sites

#7   Posted

thanks for having a look 3dKiwi.. bummer

Share this post


Link to post
Share on other sites

#8   Posted (edited)

set collision eps to .01 and up the adpative sampling to 32 64, that will help. Also take the sphere out of the solver and run the sim till the cube settles, now stop the timeline and go dynamics-initialise object. This will set the cube in a settled state for the start of the sim and you can now put the sphere back in

you may also want to check colision use rest speed, this, i think adds some jitter to the objects that have otherwise stiopped moving and helps in the sinkage problem

When you slide an object over a surface using Dynamics, under some circumstances, the object may start to sink through the surface.

The Collision Rest Speed parameter is designed to prevent this sinking from happening. When the Use option is enabled, it will give the sliding object a little push away from the surface (in the direction of the surface’s normal, that is).

To prevent this little push from being added to rebounding objects that are not sliding, the push will be exerted only if the object’s velocity in the direction of the surface is below a certain velocity — this threshold velocity is the Collision Rest Speed.

For an object to rest on a surface, the distance between the object and surface must be less than the Eps distance and the object’s velocity must be less than the Collision Rest Speed. Static drag will then take hold.

Edited by paulselhi

Share this post


Link to post
Share on other sites

#10   Posted

Great! thanks Paul! Helps a lot...

Share this post


Link to post
Share on other sites
This topic is now closed to further replies.
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.