Sign in to follow this  
Followers 0

Rendering - Banding In Reflection

28 posts in this topic

Posted

Hi,

I have a light setup that WORKS great in most scenes but when I rendered out a scene that I made additions to...I started to get this BANDING in my reflections of screen. I know its not entirely the lights or render setups for they are the same....

Is there any suggestions how to eliminate the banding in reflections to smooth out? When I preview render in UI...its not there but when I actually start rendering....banding nightmare!

Thanks,

-3D

Share this post


Link to post
Share on other sites

Posted

lower the phong amount to about 14.

Share this post


Link to post
Share on other sites

Posted

hhmmm let me try. I think we got it by putting the scene on the same machine it was lit. So it works now. Next time I will consider phong alterations.

Share this post


Link to post
Share on other sites

Posted

Okay, I did change the phong and the results are still the same. Even turned it off and still same results. Any other suggestions?

Share this post


Link to post
Share on other sites

Posted

Try lowering the threshold in render settings.

Cheers

Share this post


Link to post
Share on other sites

Posted

It just takes a bit longer but still banding. Posterization in back ground now. I did change document settings to linear workflow when I hit cmd + d. And the input color profile is sRGB and default object color is 80 percent grey. Do I uncheck Linear workflow or change input color profile? Could of sworn I did this and problem still remains.

Any ideas?

Share this post


Link to post
Share on other sites

Posted

It's 100% reflections? Not shading at all or anything related to shadow bias?

Share this post


Link to post
Share on other sites

Posted

Yes there are some 100 percent reflections and some are up to 400 percent. Yes, Do have nice setup shaders going on. shadow bias? What might I need to change to deplete banding with the current shaders I have.

-3D

Also, I don't want to render with GI.

I know it fixes it but we faked GI with light setups and material shading to not really need GI. Concentrating on optimizing for rendering.

-3D

Share this post


Link to post
Share on other sites

Posted

I keep reading a lot of forums and many mention set 24 bit dithering under save settings but I can only select 8 bit. any suggestions how to change this? Wonder if this would fix my problem. Also I am using ambient occlusion for the record.

Any other suggestions would be grand.

Share this post


Link to post
Share on other sites

Posted

could you post a render of the problem.

or even better a scene file

Share this post


Link to post
Share on other sites

Posted

Unfortunately, I can't share the scene for its proprietary for the company I am working for. But here is a screen shot showing that the preview render in the UI of C4D is more to my liking as compared to the final output in picture viewer. WHY IS THAT? How come the render in the UI is much better than the final output?

Thanks for the aid.

-3D

post-114201-0-85486100-1319261620_thumb.

Share this post


Link to post
Share on other sites

Posted

have you tried increasing the AA?

Share this post


Link to post
Share on other sites

Posted

That is the first thing I did. Its set to BEST-Animation 2x2 4x4. We never go higher than 2x2 by 4x4 for render times escalate. This is getting VERY annoying. C4D just started acting random with a template scene that we always use. It is doing this on all machines which are MACs OSX Snow leopards. Very frustrating. I spent 3 days effin with this problem.

-3D

Share this post


Link to post
Share on other sites

Posted

how about a graphic card update

Share this post


Link to post
Share on other sites

Posted

Thats what I thought too but we only had these MAC SNOW LEOPARD machines for a month and they are already up to date. Normally through system update, it also updates graphics card. I am attaching a c4D project zip file for I am already growing old sending pictures of my problem. The scene is lit with NO LIGHTS and uses geometry to illuminate the scene. This will eliminate problem solving with lights with soft shadows, inverse physical properties and radius issues that can normally cause banding/posterization in your renders. Normally I don't use GI but rather fake it to eliminate constant tweaking and long render times. Normally GI eliminates such issues but as you can see with new snap shots, its not doing me justice with GI on.

Also, in this shared studio lit scene, reflection is 10 percent so its not over 100 percent as Keign suggested. Last time I had this problem, I restarted my computer and it fixed it. But now, thats not the case and this is happening on 3 other Mac SNOW LEOPARD machines.

One more thing, I turned off LINEAR WORKFLOW sRGB for that was the ONLY THING I did different on these rounds of rendering. You can see in picture, final output is 32 bit with 8 bit dithering initialized through save submenu under RENDER SETTINGS.

Any other suggestions is much obliged.

-3D

TestProject.zip

post-114201-0-24635400-1319352127_thumb.

Share this post


Link to post
Share on other sites

Posted

not getting the same results.

think its a SNOW LEOPARD thing i have seen a few posts that are problems related to running SNOW LEOPARD

Share this post


Link to post
Share on other sites

Posted

hhhhmmmm But you can see the difference in the picture right? I am completely confused if you are not getting the same results. Let me restart my computer again...

Can you show me a snap shot as well so I can compare and have means to explain myself with those large and in charge?

Thanks,

-3D.

PS- Anymore feedback would be much appreciated.

Share this post


Link to post
Share on other sites

Posted

Okay nvm....at least for now. I just restarted the computer AGAIN but this time I unchecked "reopen apps when restart." I am guessing what ever application that was open messes with C4D render outputs. Odd because I restarted several times before and the other machines still makes banding. At least my computer is back up to standards. I appreciate all of you wonderful dude's time!

-3D.

Share this post


Link to post
Share on other sites

Posted

Okay, never mind....still banding. This is annoying! Got deadlines and our client already called us out on these crappy posterization problems. NOTHING IS WORKING...I am about to go put my head between a door and shut it.

Share this post


Link to post
Share on other sites

Posted

here is a screenshot

post-21531-0-12972500-1319358230_thumb.p

have you tried adding a normal light into the scene.

im thinking it might be the Gi

Share this post


Link to post
Share on other sites

Posted (edited)

OSX 10.6.8, R12, two results. First with 'Use Render LOD' disabled, as it is in your test scene.

Second with 'Use Render LOD' enabled.

[edit] I don't see any difference between the 2 but I include them both because I thought there might be a difference.

Edited by SKP

Share this post


Link to post
Share on other sites

Posted

Thanks for the post. Actually, no, the actual scene I am using has no GI and I do have lights rather objects that emit light. I don't understand why this is not rendering to as how it is setup to.

Even when I have GI on or off...the banding is still there. I am trying other computers again. My station is pissing me off...lol. I don't know, I hate Macs...I am normally on PC but everyone in office is Mac obsessed. I am glad you shared your rendered version so I can share to the boss.

Share this post


Link to post
Share on other sites

Posted

SKP, I can see the renders are looking good from your end. I activated LOD under render settings...I still have banding problems. I don't have banding problems in the scene shared though. However, I am seeing them again in my actual scene used for work. I cropped a piece of what I am dealing with from actual scene being used for work.

Have a look see....

post-114201-0-34756900-1319363301_thumb.

post-114201-0-08578400-1319363311_thumb.

post-114201-0-07513600-1319363324_thumb.

post-114201-0-19249100-1319363345_thumb.

Share this post


Link to post
Share on other sites

Posted

Oh, and I went to viewport under DISPLAY to turn on "Use Render LOD for editor rendering" - I think that is what you meant correct? I turned it on...still the same problem. Confused.

Share this post


Link to post
Share on other sites

Posted

uuugghhh! I am getting tired of messing with rendering with this problem. However I am getting close by pressing cmd + d to access PROJECT SETTINGS and turned on LINEAR WORKFLOW...AGAIN... with view clipping set to medium and INPUT COLOR PROFILE to sRGB. THEN I went to render settings and under SAVE submenu, I changed IMAGE COLOR PROFILE to match PROJECT SETTINGS and changed it to LINEAR COLOR SPACE. Before it was set to sRGB IEC61966-2.1. I also went to SYSTEM PREFERENCES for MAC and made sure display was set to LED Cinema Display. At first under the system preferences for Mac Display, I changed it to match sRGB IEC61966-2.1 when C4D was set to sRGB IEC61966-2.1 but still had problems with banding. So I switched it back to LED Cinema Display and just changed the rest as explained before.

I mean there is still some banding but its not as recognizable as before. It seems to be very noticeable when the light's falloff/specularity towards an object. I have altered custom shaders, lights and render settings but switching sRGB IEC61966-2.1 to LINEAR WORKFLOW and do the same under the SAVE submenu helps.

Any additional comments are more than welcome but so far this is my standpoint.

-3D

Share this post


Link to post
Share on other sites
This topic is now closed to further replies.
Sign in to follow this  
Followers 0