Jump to content




Photo

Sketchup import formats?


  • This topic is locked This topic is locked
9 replies to this topic

#1 carlk

carlk
  • Regular Member
  • 46 posts
  • C4D Version:13 Studio
  • Location: Seattle

Posted 13 March 2010 - 04:53 PM

Greetings,

My son, Ben Kadie, would like to import a model Google 3D Warehouse to C4D. Using Sketchup Pro 7 (free for 7 hours of use), we've exported the model to many formats. But every import to C4D has problems, mostly with textures. For example:



Ben would be grateful for help converting this model. Also, we'd both love to know what's going wrong and if anything can help in the future.

The model in all the different formats is available as a 50 meg zip file from mansion.zip

Thanks,
Carl & Ben
http://slugco.com

#2 carlk

carlk
  • Regular Member
  • 46 posts
  • C4D Version:13 Studio
  • Location: Seattle

Posted 13 March 2010 - 04:55 PM

Please use the Image attachment facility. Remote linking and embedding is not allowed.

Attached Files


Edited by Rantin Al, 13 March 2010 - 06:33 PM.
Embedded images.


#3 3DKiwi

3DKiwi

    Cafe Founder

  • Admin
  • 41,013 posts
  • C4D Version:15 Studio
  • Location: Feilding, New Zealand

Posted 13 March 2010 - 08:13 PM

Have you tried exporting in Obj format? Then in C4D you can use the free "Riptide" plugin to import the model and textures.

Hope this helps.

3DKiwi

www.3dkiwi.co.nz - My personal site    Follow me on Strava


#4 sjcrompo

sjcrompo

    Cafe Master Blaster

  • Moderators
  • 6,158 posts
  • Location: UK Stockport Cheshire

Posted 13 March 2010 - 11:48 PM

Hi

Try using the Collada format. That brings through the textures and pretty good geometry too.

Cheers

Steve
Interactive DVD now available from www.dvdlearningmagic.co.uk

#5 stevehewitt1950

stevehewitt1950

    SteveMacc

  • Regular Member
  • 3,508 posts
  • C4D Version:11.5 (or older)
  • Location: Manchester, UK

Posted 14 March 2010 - 12:57 AM

Try Collada. I reimported your model into Sketchup then re-exported as a dae file and apart from a couple of reversed faces it worked OK.

However, check the following. Before exporting, explode the group. Then go to Window -> Model Info -> Statistics and click purge unused. When you export to Collada, select options and untick export 2 sided faces, tick triangulate all faces, export texture maps. The rest should be unticked. When you import in to C4D, tick the Fix transparency box.
Steve

#6 carlk

carlk
  • Regular Member
  • 46 posts
  • C4D Version:13 Studio
  • Location: Seattle

Posted 14 March 2010 - 07:19 AM

Steve,

Thanks! The steps you suggested worked great. The result so far is attached. (Also, below are the notes I made for Ben and me for the future).

One follow up question: What is the easiest way to fix the reversed faces? I can select with the Polygon tool and right click and see many options, but don't know which to use or if this is the best way.

- Carl


Notes on importing for Sketchup:

IN SKETCHUP PRO 7
Tools, Select, click the model
Edit, Group (1 in model), Explode
Window, Model Info, Statics, Purge Unused
File, Export, 3D Model, export type: Collada File, Options (lower right hand corner)
Only "Tranagulate All Faces" and "Export Texture Maps" should be ticked.
Save

IN CINEMA 4D
Edit, Preferences, Import/Export, COLLADRA Import, Fix Transparency for incompaible files
File, Open, the file
To fix reversed normals, ????

Attached Files



#7 hulaboy

hulaboy
  • Regular Member
  • 1,643 posts
  • C4D Version:13 Studio
  • Location: The Deep South.... West, UK

Posted 14 March 2010 - 08:12 AM

Function>Reverse Normals - if you have the reversed polygon(s) selected.

Function>Align Normals - with the object selected in the OM but no polygons selected.

Cinema's materials are double-sided by default, but if you apply a strong one-colour material to the entire mesh and set it to Back only, it may help in identifying where there are reversed normals.

Mark

#8 stevehewitt1950

stevehewitt1950

    SteveMacc

  • Regular Member
  • 3,508 posts
  • C4D Version:11.5 (or older)
  • Location: Manchester, UK

Posted 14 March 2010 - 11:09 AM

It's best to get the faces facing the right way in Sketchup before you start. They show blue if they are pointing the wrong way (turn on View-> Face Style -> Monochrome). You can try Orient faces or for individual faces Reverse Face but there is a plugin available that allows you to paint all the faces and they turn so that outward is towards the camera. It is called FrontFace and is a real timesaver. Unfortunately, because Sketchup is very forgiving about normals, a lot of the models on Google Warehouse suffer from this problem.

Unfortunately, the texture will not be correct after the normals have been corrected, so the textures often need reapplying. It would be better for models intended for export if Sketchup didn't show the reversed face in the first place (i.e. it was invisible). It would be more obvious. I suppose beginners would get confused though with invisible walls etc.

Edited by stevehewitt1950, 14 March 2010 - 11:18 AM.

Steve

#9 carlk

carlk
  • Regular Member
  • 46 posts
  • C4D Version:13 Studio
  • Location: Seattle

Posted 16 March 2010 - 12:59 PM

Thanks to everyone for their help. We have a much better idea of what is going on, but sadly we still can't get it working. Like people have said, it really seems to have to do with normals, but nothing we try (including the Sketchup Greyscale/Facefront add in) seems to work for us.

At this point Ben would be grateful to anyone who could convert the model for him. Here is the direct 3D Warehouse link:
http://sketchup.google.com/3dwarehouse/details?mid=d0a49a3305229e565bc7a59f3ad92e52&prevstart=24

Secondarily, we would love to figure out what we're doing wrong so we could do this for ourselves in the future.

Thanks!

- Carl

p.s. Some production photos for the film that this is for: http://slugco.com/movies/MaskedStorm/

#10 carlk

carlk
  • Regular Member
  • 46 posts
  • C4D Version:13 Studio
  • Location: Seattle

Posted 21 March 2010 - 01:15 PM

[Greetings, with help from Steve in this form and then xrok1 in the SketcupUcation forum, we now have a pretty good manual way to fix "inside out" Sketchup models. Thanks! - Carl]

http://forums.sketchucation.com/viewtopic.php?f=323&t=27058&p=233771&hilit=inside#p233771

Report this postReply with quoteRe: Fixing "inside out models"
by xrok1 on Thu Mar 18, 2010 4:15 pm

if you use the materials window eye dropper (sample paint) tool to click a face, then right click, texture>projected, then right click, reverse face, then left click to paint with sampled texture. for the next face hold down alt to sample and so on... you have to do this face by face but its the only way i can think of.Attachments

Attached Files






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users