Jump to content




Photo

Cloth collider


  • This topic is locked This topic is locked
3 replies to this topic

#1 ghirardo

ghirardo
  • Regular Member
  • 61 posts
  • C4D Version:13 Studio

Posted 04 November 2010 - 12:42 PM

Hello everyone

I am trying to animate some A4 sheets of paper flying like the image attached.
The whole scene is built with c4d 12 and the problem I have is that the sheets of paper do not collide with each other.
Could you tell me what is wrong with it?

Thanks

Here is the file I am building

Attached Files



#2 Horganovski

Horganovski

    Toon in:Power on:Ease out

  • Moderators
  • 9,913 posts
  • C4D Version:15 Studio
  • Location: Ireland

Posted 04 November 2010 - 02:10 PM

For cloth to cloth collisions to work all of the meshes need to be Connected into one mesh. You can do this using the Connect and Delete command after selecting them all. Then make sure to enable self collision in the expert tab of the cloth tag. You'll need a pretty powerful computer to be able to handle this kind of thing though if you want a look like your image with a so many pages.

Edit- here's an example.

Cheers,
Brian

#3 SolarExpress

SolarExpress

    SolarExpress

  • Regular Member
  • 367 posts
  • C4D Version:12 (or older)
  • Location: UK

Posted 04 November 2010 - 02:31 PM

Hi Brian,

Your 'Connect' method works well.

Edit: This is interesting as although the planes are connected as one they are still independent as far as the forces acting upon them. Perhaps I am not understanding what 'Connect' actually does, can you explain please?

I tried putting Cloth Collider tags on each plane and that doesn't work at all for some reason.

It's usually best to use Cloth NURBS rather than HyperNURBS or a combination of the two and Cloth tag > Expert > Increasing 'Sub Sampling' can sometimes help reduce mesh penetrations if they are occuring.

Cheers,

SolarExpress

Edited by SolarExpress, 04 November 2010 - 02:41 PM.

SolarExpress site: http://www.stereo3drender.com

#4 ghirardo

ghirardo
  • Regular Member
  • 61 posts
  • C4D Version:13 Studio

Posted 05 November 2010 - 02:43 PM

Thank you very very much for your help.
That works great now. :signthankspin:

Edited by ghirardo, 05 November 2010 - 02:43 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users