Jump to content




Photo

Rendering - Banding In Reflection


  • This topic is locked This topic is locked
27 replies to this topic

#21 SKP

SKP

    Hopeless

  • Regular Member
  • 5,281 posts
  • C4D Version:13 Studio
  • Location: Scotland

Posted 23 October 2011 - 12:30 AM

OSX 10.6.8, R12, two results. First with 'Use Render LOD' disabled, as it is in your test scene.

Second with 'Use Render LOD' enabled.

[edit] I don't see any difference between the 2 but I include them both because I thought there might be a difference.

Edited by SKP, 23 October 2011 - 12:45 AM.

I may not be good but I'm slow.

#22 Dementia

Dementia

    Quantum 3D

  • Regular Member
  • 123 posts
  • C4D Version:15 Studio
  • Location: USA

Posted 23 October 2011 - 01:21 AM

Thanks for the post. Actually, no, the actual scene I am using has no GI and I do have lights rather objects that emit light. I don't understand why this is not rendering to as how it is setup to.

Even when I have GI on or off...the banding is still there. I am trying other computers again. My station is pissing me off...lol. I don't know, I hate Macs...I am normally on PC but everyone in office is Mac obsessed. I am glad you shared your rendered version so I can share to the boss.

#23 Dementia

Dementia

    Quantum 3D

  • Regular Member
  • 123 posts
  • C4D Version:15 Studio
  • Location: USA

Posted 23 October 2011 - 01:49 AM

SKP, I can see the renders are looking good from your end. I activated LOD under render settings...I still have banding problems. I don't have banding problems in the scene shared though. However, I am seeing them again in my actual scene used for work. I cropped a piece of what I am dealing with from actual scene being used for work.

Have a look see....

Attached Thumbnails

  • Screen Shot 2011-10-23 at 4.27.59 AM.png
  • Screen Shot 2011-10-23 at 4.27.39 AM.png
  • Screen Shot 2011-10-23 at 4.39.20 AM.png
  • Screen Shot 2011-10-23 at 4.39.15 AM.png


#24 Dementia

Dementia

    Quantum 3D

  • Regular Member
  • 123 posts
  • C4D Version:15 Studio
  • Location: USA

Posted 23 October 2011 - 01:58 AM

Oh, and I went to viewport under DISPLAY to turn on "Use Render LOD for editor rendering" - I think that is what you meant correct? I turned it on...still the same problem. Confused.

#25 Dementia

Dementia

    Quantum 3D

  • Regular Member
  • 123 posts
  • C4D Version:15 Studio
  • Location: USA

Posted 23 October 2011 - 03:51 AM

uuugghhh! I am getting tired of messing with rendering with this problem. However I am getting close by pressing cmd + d to access PROJECT SETTINGS and turned on LINEAR WORKFLOW...AGAIN... with view clipping set to medium and INPUT COLOR PROFILE to sRGB. THEN I went to render settings and under SAVE submenu, I changed IMAGE COLOR PROFILE to match PROJECT SETTINGS and changed it to LINEAR COLOR SPACE. Before it was set to sRGB IEC61966-2.1. I also went to SYSTEM PREFERENCES for MAC and made sure display was set to LED Cinema Display. At first under the system preferences for Mac Display, I changed it to match sRGB IEC61966-2.1 when C4D was set to sRGB IEC61966-2.1 but still had problems with banding. So I switched it back to LED Cinema Display and just changed the rest as explained before.

I mean there is still some banding but its not as recognizable as before. It seems to be very noticeable when the light's falloff/specularity towards an object. I have altered custom shaders, lights and render settings but switching sRGB IEC61966-2.1 to LINEAR WORKFLOW and do the same under the SAVE submenu helps.

Any additional comments are more than welcome but so far this is my standpoint.

-3D

#26 Dementia

Dementia

    Quantum 3D

  • Regular Member
  • 123 posts
  • C4D Version:15 Studio
  • Location: USA

Posted 23 October 2011 - 10:17 AM

Okay, now I have another problem. When set to Linear Color Space, in After Effects, the C4D rendered items are way too dark. So I add levels to it but man oh man...banding is worse. Its not as so in C4D picture viewer but it is in AE. I don't have these problems when working on PC....am I missing something? I am going nuts here.


EDIT:

Okay I found that rendering to 16bit channel on PNG format, then integrating in After Effects, you need to make 8 bpc to 16 bpc I guess from there, you can add ramp effect and add scatter to relieve what little is scene from banding. Really, I don't remember going through all this process just to get a render to how it should be. So any suggestions would be much appreciated.


THanks,

-3D

Edited by Dementia, 23 October 2011 - 10:21 AM.


#27 Dementia

Dementia

    Quantum 3D

  • Regular Member
  • 123 posts
  • C4D Version:15 Studio
  • Location: USA

Posted 23 October 2011 - 12:13 PM

okay I did at least find out its the lights in the scene. The scene I shared without lights was easier to fix...but the actual lights used in the scene actually used, I found it was the lights. Any ideas how to alter light settings to prevent banding?

#28 Dementia

Dementia

    Quantum 3D

  • Regular Member
  • 123 posts
  • C4D Version:15 Studio
  • Location: USA

Posted 23 October 2011 - 01:04 PM

Update....I think I found a workaround. What I did was added a noise to the material/texture specifically Poxo noise and changed global scale small like 5 percent. Then changed the detail attenuation to 296-300. Delta to 55 percent....and the last setting that I changed that hit the money was the CYCLES property. I changed it 5.5.

I tried to do this all in post but the banding was too big to add noise filters to blend them. To do it in C4D under the color channel...all it took was adding NOISE. Everything else is left default.

For reflections, you should add the same settings under NOISE channel of the material. Well at least in the setup I have for reflections I can add noise. Speaking roughly, the reflection setup is established by making a DOME, adding a BLACK FILL material(Luminance channel ONLY and set color to black) then add another material and make an alpha channel that has luminance as well. Under Alpha, just add a gradient. What you should have is a dome that has TWO MATERIALS, first mat will be black luminance and the other mat with alpha and luminance will create a reflection. Now you can add NOISE to the material to do what was mentioned before. In addition, you can just ROTATE your dome that has the reflection material to control your HARD EDGE reflection...you have complete control of your reflections rather to use an HDR image.

These links helped:

http://forums.cgsociety.org/archive/index.php/t-987946.html

and

http://forums.creativecow.net/archivethread/19/627981 (This one gave me ideas)

and

http://greyscalegorilla.com/blog/2009/10/how-to-remove-banding-artifacts-in-after-effects/ (For POST Production)

Thanks anyways fellas, FINALLY, I can move on. I also read up where someone mentioned to calibrate the monitor. Soon as I tested on other PC's and other MACs, I found the problem still remained. So it was the lights in the scene that caused the banding problem.

Hope this will help someone in the future.

-3D.



EDIT:

Forgot to mention that under the color channel of your material where you added Noise under TEXTURE, you need to change MIX MODE to MULTIPLY.

Edited by Dementia, 23 October 2011 - 01:06 PM.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users