Jump to content




Photo

Why Are My Particles Rendered Differently In My Render Viewer To External Renderer


  • This topic is locked This topic is locked
4 replies to this topic

#1 PhilDon

PhilDon
  • Regular Member
  • 20 posts
  • C4D Version:14 Studio
  • Location: Chalfont St Peter

Posted 24 February 2012 - 04:24 AM

I've set up pyro cluster particle emmitter and stopped it at frame 85, it looks great in my render viewer, but when I render it to file in the external renderer the pyrocluster effects are completely different - it's really doing my nut in.

I'm just looking for a still image, so it's important to get the one frame looking perfect.

I've got some depth of field in there, but pyrocluster isn't an after effect so it can't be that. I've got the render settings rendering at 'current frame', I'm sure it's something stoopid that I've missed, though I've always had this problem everty time I use pryo.

Please can someone help.

#2 srek

srek
  • Regular Member
  • 3,666 posts
  • C4D Version:16 Studio
  • Location: Germany Friedrichsdorf Hessen

Posted 24 February 2012 - 05:00 AM

Are you using standard particles? If yes make sure that editor and render settings are identical for the emitter, otherwise the number and distribution of particles will be different between editor and PV rendering.

#3 PhilDon

PhilDon
  • Regular Member
  • 20 posts
  • C4D Version:14 Studio
  • Location: Chalfont St Peter

Posted 24 February 2012 - 05:27 AM

Are you using standard particles? If yes make sure that editor and render settings are identical for the emitter, otherwise the number and distribution of particles will be different between editor and PV rendering.

What a fabulous site C4D cafe is - a reply from MAXON royalty no less thanks Bjorn - I think I met you at the training day in London.

I don't want to drag you into a full tutorial, but I'm sorry I can't find the section that relates to particle emmitters in render settings, I've already looked for it and couldn't find it, so I assumed the settings would be adopted from the main program. I assume I'm using a standard emmiter, I didn't do any fancy xpresso tags, I'm not that good yet :0(

#4 srek

srek
  • Regular Member
  • 3,666 posts
  • C4D Version:16 Studio
  • Location: Germany Friedrichsdorf Hessen

Posted 24 February 2012 - 05:53 AM

It's not part of the rendersettings but of the particle emitter object. Check that Birthrate Editor and Birthrate Renderer are set to identical values. If you already like how it looks in the editor set the birthrate renderer value to the same as brithrate editor, the result should be identical then.

I hope you had as much fun at the training day as i had, it was nice to meet so many cc4d users in London.

Cheers
Bjorn

#5 PhilDon

PhilDon
  • Regular Member
  • 20 posts
  • C4D Version:14 Studio
  • Location: Chalfont St Peter

Posted 24 February 2012 - 06:13 AM

It's not part of the rendersettings but of the particle emitter object. Check that Birthrate Editor and Birthrate Renderer are set to identical values. If you already like how it looks in the editor set the birthrate renderer value to the same as brithrate editor, the result should be identical then.

I hope you had as much fun at the training day as i had, it was nice to meet so many cc4d users in London.

Cheers
Bjorn

:)
That's gotta be it, I did have different settings - brilliant - seems obvious now, thanks so much. Takes a while to render despite my 12 core, so won't know immediately ... but I trust your advice.
Yes loved the training day. Just wish I had the time to learn more Xpresso, it would be very useful, but I'm working all the time, a lot of it on C4D these days which is great, but I generally have to stick to the functions that I know well because of time/budget constraints.
Loved the stuff you showed us - hope you come back for more training days in the future - just bring your files with you next time Bjorn - ha ha ha :wackywink:

Thanks

Phil

Edited by PhilDon, 24 February 2012 - 06:14 AM.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users