Jump to content

Archived

This topic is now archived and is closed to further replies.

pfistar

Keyframes won't stick. Very frustrating!

Recommended Posts

  • Topic Author
  • Help! Keyframes won't stick to timeline. Very frustrating!

    Greetings all!
    I’ve encountered this problem before, but it was months ago so I don’t recall what the fix was. I have to imagine that there’s a single hidden function somewhere in the UI that I’ve activated or deactivated by accident.  In any event, I’m trying to animate a camera by 
    - selecting it in the Object Manager window, 
    -making it the active camera in the viewport, 
    - Moving the timeline marker to the desired frame
    - setting to red the circular toggle buttons to the immediate left of position and rotate fields
    - Moving timeline marker to the next desired frameUsing the viewport controls to adjust the position and rotation of the camera
    - Setting again to red the circular toggle buttons on  position and rotate

    This workflow was working well for me for several days on my current project.
    Now, out of the blue, this is what happens when I try the same order of operations:
    -Select camera object and make it active viewport
    -Move the camera and timeline into 1st desired place
    -Set keyframe using toggle buttons - toggle buttons turn red
    -Move the camera and timeline into 2nd desired place
    -Set keyframe using toggle buttons - toggle buttons turn red
    -when I scrub the timeline backwards to check the motion, the keyframe toggles turn yellow, 
    -the position/rotation values at 2nd key remainthe position/rotation values at 1st key are now the same as 2nd key
    -banghead.gif

    I should mention that I’ve created many Takes within my scene, as I suspect there’s a chance this might be related to my problem.  However, I’ve taken care to always set the Main Take as the active Take when creating and animating new cameras within the scene.
    I’ll also mention that I’ve tried to replicate the problem in a brand new scene file, though when I go through the steps above, I have no problem getting the keyframe values to adhere wherever I set them in the timeline.
    Any help is hugely appreciated!
    Thanks and best,NpF

    Share this post


    Link to post
    Share on other sites

    Please update your profile to the correct version - R16 doesn't have takes !

     

    The way to see if takes is breaking stuff would be to try that again in a new scene without them - does that work ? If so pls upload a screenie of the GUI so we can see if you have the right things activated.

     

    CBR

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Hi CBR

     

    Thank you for the response. I've updated my profile to show current version.

     

    I took you advice and copy/pasted my all of my scene objects to a new scene, then set up a new set of takes from scratch. That worked - at least for a little while, though eventually I experienced the phenomena again (non-stick keyframes) but fortunately only occasionally. I'm still on alert for its cause, and still can't say for sure there's a definite correlation between  keyframes being non-adherent and the presence of Takes.

     

    If I figure it out I'll be sure to post something.

     

    Thanks again for the reply,

    NpF

     

     

     

    Share this post


    Link to post
    Share on other sites

    • Recently Browsing   0 members

      No registered users viewing this page.

    Latest Topics

    Latest Comments

    ×
    ×
    • Create New...