Jump to content

Sign in to follow this  
DrDisco

Weighted character problem

Recommended Posts

Hello there, i know that i am spamming a bit but i encountered a serious problem with my character.

 

As you can see on the picture, i've weighted my character properly (i've double checked it), but in the renderer it, shows this weird mesh after its starts moving.

Importrant note: The broken part of the arm was modelled after i rigged the character, so i was modelling an already rigged object. I was basically extruding the existing polys and weighed the new ones. Altough it looks fine in the viewport, the renderer shows the opposite. Any ideas how to fix that without reweighting that all again? Thanks!

problem nevim.jpg

problem nevim2.jpg

problemy.jpg

Link to the project: https://drive.google.com/file/d/1RTgAjSgMVDdsHyK7F0yrKDRdHiNCMyEk/view?usp=sharing

Share this post


Link to post
Share on other sites

Hi, it's possible that when you extruded the polygons some vertices are not weighted, just paint the weight on the stretched area. Here is a short example of the problem: https://m.youtube.com/watch?v=czfWdmNTB7s

Share this post


Link to post
Share on other sites
  • Topic Author
  • That is the problem, because i have weighted all the polys with the weight tool that had visible only unchecked, so theres no way it can not be weighted properly. It only appears in renderer. I've also tried to delete the whole arm, but all the problem still presists. Thanks anyway!

     

    Share this post


    Link to post
    Share on other sites

    I'm no expert in c4d rigging but perhaps you have to rebind the mesh to the skeleton?

     

    Philip

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Already tried that, unfortunately does not work either :(

    Share this post


    Link to post
    Share on other sites

    Just fix this points in the weights manager
    https://www.dropbox.com/s/vwcfthi5mlf8hto/2017-11-09_9-28-38.jpg?dl=0

    In the end, the result should be something like this.
    https://www.dropbox.com/s/ic7xim9p1hfctzm/2017-11-09_9-28-38.rar?dl=0

    P.S. Can you rar your file next time before sending?

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Well there goes my skill again.  Sorry, i was so confused, because i could not see that in the viewport, therefore i could not paint that with the tool. You saved me dude! Thanks!

     

    Share this post


    Link to post
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    Latest Topics

    Latest Comments

    ×
    ×
    • Create New...