Jump to content
Rendercore Lab

asaul

Selection question

Recommended Posts

asaul    1

Hello,

 

Whenever I select an object in the viewport that's under a null object, it selects everything under the null instead of just the one. This gets annoying since I don't want to have to go to the object manager every time since I have multiple objects under multiple nulls. Is there a way to stop this selection result?

 

Thanks!

Share this post


Link to post
Share on other sites

asaul    1
  • Topic Author
  • For some reason, double clicking still selects all the objects under the null. Is there some kind of selection lock in cinema that I might have accidentally turned on?

    Share this post


    Link to post
    Share on other sites
    Cerbera    1,254

    Weird - works for me every time, no matter how many layers of nulls there are. Maybe it's a bug in the student version, though that seems unlikely...

     

    CBR

    Share this post


    Link to post
    Share on other sites
    asaul    1
  • Topic Author
  • Hmm, I'll try opening it in another window. Thanks for taking the time to reply!

    Share this post


    Link to post
    Share on other sites
    asaul    1
  • Topic Author
  • Actually, I realized that if I take the null object out of symmetry, I can select the individual objects in the viewport just fine. Is there any reason the symmetry would be causing the selection problem?

    Share this post


    Link to post
    Share on other sites
    Cerbera    1,254

    No - that works for me symmetry or not :/

     

    CBR

    Share this post


    Link to post
    Share on other sites
    ABMotion    113

    As @Cerbera originally told you, but I think you might not be doing, double-click the individual object you want to move.

     

    If you have the Null under a Symmetry, the Symmetry is the parent and therefore you can't select the individual Cubes by single clicking in the viewport because a single click is actually selecting the Symmetry (or parent) Object by default. You either have to double-click to select them or highlight them in the Object Manager.

    Share this post


    Link to post
    Share on other sites
    asaul    1
  • Topic Author
  • Yes, it's really strange. I'm in model mode double clicking objects but it still selects everything under the null. I tried copy and pasting everything to another window and the selection is actually fine for a while, then eventually reverts to selecting everything again. 

     

    I've attached an image of what the attribute manager says when I double click a single object. It says 2 Elements, but everything is selected. Would this mean anything? Thanks for all the help!

    help.PNG

    Share this post


    Link to post
    Share on other sites
    Cerbera    1,254

    Load this test scene. You should be able to double click any object in the viewport to select it, or its symmetry original. Does this work for you ? If so, it may be something about your specific scene that is wrong. Perhaps upload that so we can check it.

     

    test dclick.c4d

     

    CBR

    Share this post


    Link to post
    Share on other sites
    Cerbera    1,254

    OK, I can d-click any object in your scene and no problems at all. Have you tried restarting the computer ? This could be one of those weird session errors that happens occasionally when you've had the app open for a while...

     

    CBR

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×