Jump to content


shodty

Sound Effector Decay not rendering

Recommended Posts

shodty    0

I'm losing my mind. I am using a sound effector to animate  the position of a grid of cloned objects, and the Decay parameter is not factoring in upon render. 

 

If I play the animation in my viewport, it is affected exactly as I want, with a decay of 50% (things slowly fall back into place). But then when I go to render, the rendered product is as if the decay was 0%.

 

I tried making a new scene with nothing in it except a cloner with a cube in it and the sound effector acting on it, and the same problem occurs where the decay parameter I set is completely ignored.

 

What am I doing wrong?

 

I am working in R19, educational license.

Share this post


Link to post
Share on other sites

ABMotion    118

The viewport animation matches exactly the same as the render for me in R19.024 Studio.

 

A couple of things to check though:

You're using Octane Render and that doesn't work with Sketch & Toon. Are you using Octane or Standard Renderer when you render?

You have a cache tag on your Cloner. Check cache isn't playing a factor, although it's not active on the file provided, so it shouldn't be a problem if yours matches.

The actual Decay setting on the Sound Effector is set to 0% with no keyframes. Not sure what you mean by decay, if it's the natural decay or you're expecting something else.

 

The only other issue I could imagine is if your viewport isn't drawing frames at 30fps (your project/render setting) and would then give you some visual difference between viewport and finished render.

 

It's hard to know what you mean just in case you're seeing something different in your viewport so if this doesn't help, can you provide a video of your viewport and a render to show what you're expecting.

  • Like 1

Share this post


Link to post
Share on other sites
shodty    0
  • Topic Author
  • I am rendering using the Standard renderer, not Octane, I just attempted to render using Octane at one point to see if it provided a different result (it didn't). 


    The cache tag is a residual from randomly trying different things to try to bake the animation in somehow, but you are correct in that it is not active. 

     

    What's odd is the decay in my file is NOT set to 0%, it is set to 67% and should be so on the file I sent you...I'm wondering if this is somehow the issue? That it's glitching and not actually committing the Decay parameter I set? I have C4D installed both on my desktop (Windows 10) and my Macbook Pro and the issue happens on both computers, so I don't think it's a faulty install. 

     

    Here is an imgur album with the issue illustrated via GIFs. Everything is set to 30FPS.

     

    https://imgur.com/gallery/AMNLR

    Share this post


    Link to post
    Share on other sites
    ABMotion    118
    28 minutes ago, shodty said:

    What's odd is the decay in my file is NOT set to 0%, it is set to 67% and should be so on the file I sent you...

    My screen looks entirely different to yours...are you sure we have exactly the same file? It is not the same file at all as the screenshots you've just posted. Open the one you linked to here from that actual link in the post.

     

    Your first screenshot of the settings you have on the Sound Effector don't match at all. Sampling is set to Peak, no Decay, Clamp is not ticked. Even the orange box around the actual waveform is different. The bars in the file you linked to here all move together, not shuffled in time across the bars.

     

    Better to upload the actual file you're using.

    Share this post


    Link to post
    Share on other sites
    ABMotion    118

    Update:

    I just set manually everything as you had it in your screenshot and I get the same issue.

     

    It's actually the Viewport that is wrong. You can tell by watching the waveform in the Amplitude section of the Sound Effector and have Interactive Render Region switched on in the Viewport.

     

    The Render view matches the Amplitude of the Waveform, but the Viewport does not. So it's a bug or quirk of viewport vs render that can sometimes happen. Best to submit it to MAXON Support https://www.MAXON.net/en/support/how-can-we-help/ to see what they tell you.

    • Like 1

    Share this post


    Link to post
    Share on other sites
    shodty    0
  • Topic Author
  • It is different because I've continued to fiddle with stuff to no avail. But here is the latest copy, with the same problem still happening.

    sound_effector_test2.c4d

    Share this post


    Link to post
    Share on other sites
    ABMotion    118

    We cross posted. You missed my latest post just above your last one. I get the same issue, but read what I said.

    Share this post


    Link to post
    Share on other sites
    shodty    0
  • Topic Author
  • Ok! good to know I'm not crazy. thank you so much for your time ABMotion. 

    Share this post


    Link to post
    Share on other sites
    shodty    0
  • Topic Author
  • What I don't understand is if I put the Decay at 100%, it still doesnt have any effect when I render it out, when in fact it should be freezing in place once it goes up, right?

    Share this post


    Link to post
    Share on other sites
    ABMotion    118
    4 minutes ago, shodty said:

    Ok! good to know I'm not crazy. thank you so much for your time ABMotion. 

     

    No problem. Definitely send the correct file to MAXON and submit it to see what they say.

     

    Post the reply back here if you can as well so others benefit from the answer too.

    • Like 1

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×