Jump to content


sphinxmoth

Displacement - material problem

Recommended Posts

Hi,

 

I'm a C4D beginner, and I'm having an issue when using displacement via the displacement channel when creating a material (I'm using Octane in this example). But if I'm not mistaking I had the same problem when using the C4D physical renderer.  <-- EDIT: nope, after testing it works fine in the standard CD4 material editor!

Basically, my problem is that as soon as I add a displacement texture/map in the channel, the polygon faces of whatever object the material is applied to get "split" apart, creating gaps, which of course I don't want. The higher the displacement settings are, the larger these gaps are. 

 

Attached are two pictures which, I hope, will help you understand the problem I'm having. The first is a basic platonic shape with some texture applied to it (no displacement), and the second one is the same platonic but with displacement added in the materials channel, with a height of about 10cm.

 

I think when I'm using the Deformer method (instead of putting the displacement map/texture in the materials channel), I don't get that problem. But I'm not sure why, it would be great if it could work in the materials channel, especially with Octane, which is really great for managing displacement maps.

 

Thanks a lot!

AoNKoUT.jpgNdMAjX0.jpg

Share this post


Link to post
Share on other sites

Hello, and welcome to the cafe :)

 

Is it possible somehow that your surfaces are not connected to each other ? Eliminate this as a possibility by selecting all points and optimizing. But this may not be the problem. I couldn't replicate the problem using  Standard Renderer, so I suspect it is something to do with Octane's displacement, and I don't have that so can't check.

 

It would easier to advise if we had the scene file. Please can you upload it ? (Zip it first if it is too big).

 

CBR

Share this post


Link to post
Share on other sites
  • Topic Author
  • Hi Cerbera, thanks a lot for the quick reply!

     

    I just tried the Optimize method after making the platonic shape editable, but unfortunately it didn't work...

    Then I did a test using the Physical renderer instead of Octane, and contrary to what I said in my first post, I didn't see the gaps between the polygon faces like when using Octane (just some weird edges when increasing the displacement height, but I guess that can be fixed more easily).

     

    After some research, it seems that it's a known issue with Octane, I've found several posts of people having the same problem. I managed to reduce the gaps by tweaking the Mid-level setting a bit and increasing the Phong angle of the polygon, but it didn't help a lot - the seams are still visible and that would be a very time consuming process to adjust all these things everytime I want to displace something else than a plane. (I had the same issue yesterday with another model made of cubes).

    (Apparently there's a software that corrects these problems, but it's for Windows only and I have a Mac).

     

    Here's a zip with both physical renderer & octane versions - I replaced the stone texture with a noise just so it loads more quickly :)

     

    Displacement.zip

    Share this post


    Link to post
    Share on other sites

    Ah excellent - thanks for posting your research, and sorry to hear that seems to be an Octane issue. I wonder if there might be way to circumvent it a bit more by adding a lot more segments to the platonic primitive, or by adding a bevel deformer, or doing something similar that might add more geometry at the seams, if you see what I mean... worth a go ?

     

    CBR

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • I've tried, but unfortunately I can't manage to get a seamless result... It looks as if the displacement texture was applied to every face of the polygon separately (instead of the whole polygon), creating wrinkles on the edges of the faces, which makes it very difficult to align everything nicely :(

    That's a shame, because Octane is otherwise awesome for managing displacements in the materials channel (I don't really like using the Displacer deformer because of all the additional segments that need to be added, and make my computer lag). I'm going to see if I can find more info about that online and I'll post here if I find a solution!

    Share this post


    Link to post
    Share on other sites

    Did you tried apply connect object on primitive object platonic? Since it´s primitive, for c4d haven´t any influence, but maybe for Octane, don´t know

    This is Octane issue maybe (or Mac related), because for me (win) your scene create displacement as expected...

    connect_displ.thumb.png.79fc3484566c1027fe56ce67b83de5d2.png

     

     

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • bezo: thanks a lot for testing with the connect object!

    Unfortunately it doesn't work in Octane (apparently displacement works differently in Octane than in the standard C4D materials interface, so I think that's why I'm having these issues). With the standard material editor from C4D it works fine (no gaps). 

    I tested this material in Octane with various primitive objects, and I think the only one that works fine is the plane/disk, even spheres get these visible seams...that's weird. 

    Share this post


    Link to post
    Share on other sites

    I just read about a fix fro SioPio for displacement issues in Octane. I know this an old post, but hopefully this helps OP or someone else in the future:

     

     

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×