Jump to content

Sign in to follow this  
mattide

Mapping Video To Shader Effector

Recommended Posts

Hi guys,

 

I'm trying to improve the mapping of an animation through the shader effector
onto a set of polygons that I put under a fracture object.

 

Currently only the top half of my animation is being translated to the surface into colours

so I'm searching for an effective way to scale or place the video in relation to the fracture object.

 

I included the scene files and some pictures of the scene.
Shader effector.zip

http://www.c4dcafe.com/ipb/applications/core/interface/file/attachment.php?id=169480


mapping1.thumb.jpg.25653f59957384243e8a6becef257914.jpg

mapping2.thumb.jpg.867bad2b9f6bb34cc64644accc92bdbb.jpg

Thanks in advance,
Matti

Share this post


Link to post

I can not download your file: "We could not locate the item you are trying to view".

 

But your question is about mapping, and there is literally a field called mapping in the shader tab of your first screenshot.

(here you can scale and offset the shader you are using)

Share this post


Link to post
  • Topic Author
  • @westbam the attachment should now work.

     

    I tried playing with the UV coordinates but it's really impractical since I don't have

    a visual reference of where the shader is being moved to.

    When putting a '-0.1' in the 'OffsetV' it renders me the lower part of my video but I

    can't seem to get it in the middle of the 'fracture object'.

    Any idea's on how to fit the whole shader exactly to the dimensions of the object?

    Share this post


    Link to post

    Hello mattide,
     you can make a new material, add the video you have in color channel , it doesn't matter which channel,

    then apply the material to your shader effector by going to shading tab > and use channel: color
    drag your material to the texture tag inside the shader effector,

    add a plane with the material of the video applied to it for visual reference,

    then change the projection of the shader material to frontal,
    use the texture mode to adjust your UV, "so important to check on enable axis to maintain the footage ratio" 

    and here you go

    hope i helped
     

    Mapping fix.c4d

    Share this post


    Link to post
  • Topic Author
  • @Teno

     

    Thanks a lot Teno you fixed it ;)

    Share this post


    Link to post

    @mattide

     

    No worries at all, I would appreciate a simple like if i helped,
     

    hard good luck, all the best~

    Share this post


    Link to post

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    Latest Topics

    Latest Comments

    ×
    ×
    • Create New...