Jump to content

Inline

Particles merging in X-particles 2.1

Recommended Posts

As ever I turn to this site whenever a head-scratcher comes along in my C4D Adventures.

 

I'm trying to have a flow of balls rolling on a surface towards an object. First I used the regular emitter, with balls going along a spline. It works but the balls merge and don't stay apart (like marbles). Nothing  helped (be advised I'm an amateur), so on reading this forum I tries it with X-particles 2.1. Still the same problem ... can somebody please tell me what I'm doing wrong? 

 

Thanx in advance!

 

5a56a443eeb25_Schermafbeelding2018-01-11om00_13_36.thumb.png.0dc454cdec5f227306f526e9d8fda0a6.pngBalls on Floor.c4d

Share this post


Link to post
Share on other sites

I don't have X-Particles 2.1, so can't help you there, but you can easily stop marbles merging using a regular emitter by adding Dynamics tag/s (Simulation Tags>Rigid Body) to the marbles so they can hit each other but not intersect.

Share this post


Link to post
Share on other sites
  • Topic Author
  • Tried the Rigid Body Tag, but they kept on merging while bouncing with balls of other emitters. I've included a part of the original emitter, so if you're inclined to make some adjustments, feel free ;-)

     

    CloseUp0007.thumb.png.92be3c0d7ea0c39cf8abf86b345b8983.pngBalls Regular Emitter.c4d

    Share this post


    Link to post
    Share on other sites

    Do you realise that each one of your dynamic spheres is 648 polygons and that the type of sphere you are using is the worst for simulations because of the uneven poly distribution and massive poles at either end ?! Dynamics likes low poly counts and even point distribution, but by 3 seconds into your animation there are 300 x 648 polys in the scene, all being live-booled (!) so no wonder it's struggling ! By frame 100 there are millions of polys in the scene, and dynamics has slowed to a crawl. So first thing you should do is replace those spheres with lower poly icosa sphere equivalents. 8-16 polys per sphere is more like it ! That can be a parametric object with 'render perfect' ticked to retain render smoothness (although you should be aware that some functions in Cinema require this to be disabled to work!).

     

    However I don't think this is the reason you are getting overlapping spheres. That'll be the spline wrap doing that, but I don't yet know how you can avoid the problem other than by not using it. Normally, when you use a standard emitter with dynamic objects if particles are created close to each other then they will spring apart a frame later as the dynamics kick in, and it realizes there are overlapping objects. When you spline wrap that, the dynamics breaks or somehow else collisions are ignored. 

     

    So I guess that must be a bug that persists into R19, and if that is the case, you should report it to MAXON, and possibly ask them if there is a way to circumvent that behaviour. 

     

    There will be other ways to make spheres follow a path on the ground of course. What about not using a spline at all, and just building the basic walls of a pathway, made of invisible-to-render collider blocks that guide particles where you want them to go ? Or maybe clone spheres along a spline with a random effector, and use offset to animate them ? 

     

    CBR

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Hai Cerbera,

     

    Thank you very much for your reply. I'll start with new spheres, didn't realise it was that bad!

     

    I tried the scene without a spline wrap (using X-particle 2.1 emitter with an attractor), but the overlapping spheres persist. An image of that is in my first entry. Perhaps I should upgrade X-particles? Anyway, it's an interesting journey to find things out.

    Share this post


    Link to post
    Share on other sites

    Annoyingly I only have XP 3.5 so didn't test that myself, but in the dynamic non-XP version, as soon as I disabled the spline-wrap on the standard emitter my collisions were restored. Perhaps have a look on the XP forum to see if there were problems with that version and collisions...

     

    CBR

     

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×