Jump to content


Recommended Posts

Hello, I'm sure this has been asked before and I've found answers to this problem but for whatever reason I just cant get this to work.

 

I'm animating a shopping ticket flying around in a canvas, for some reason the texture looks pixelated, the image is in high res, I set the Sampling to "None" and every other option but it looks like , especially once rendered because it looks like its blinking.

 

I want it to look as flat and clear as the original vector image would.

 

Any ideas how to solve this?

 

Thanks in advance!

Screen Shot 2018-01-13 at 1.33.13 PM.png

Screen Shot 2018-01-13 at 1.33.56 PM.png

Share this post


Link to post
Share on other sites

Hello, and welcome to the cafe

 

Don't set sampling to none - that's the very worst of the options available ! You want SAT for ultimate quality.

But it looks like you are using a ludicrously large file (16000 x 6000), and I bet that's more than 72 dpi, which will most likely be the problem.

Try downsampling the image to 72 DPI, set the sampling to SAT and it should be fine. I'm guessing you shouldn't need more than 2000 x 400 px for this.

 

CBR

 

 

  • Like 1

Share this post


Link to post
Share on other sites
  • Topic Author
  • Thanks! That helped a lot. I think it's not a 100% but for the size I'll be exporting it looks pretty close!

     

    Is there a way to further improve the quality?

     

    5a5a66d535082_ScreenShot2018-01-13at2_05_58PM.thumb.png.873dec1cbf676811a3c42416b3bc55fe.png

    Share this post


    Link to post
    Share on other sites

    If it's just the viewport and not the render that looks bad after you've made the change that @Cerbera has suggested, you can also edit the material, go to the Editor section and change Texture Preview Size from Default to No Scaling for best resolution or to a resolution closely matching the resolution of your image.

     

    Editor_Preview_Size.thumb.png.a4c2cea6c7b1255dfd3d30a9d0462d47.png

     

    If it's the render, there is not much more you can do other than reduce the original resolution as @Cerbera suggested. It should be as good as it looks in Photoshop or similar when you look at it.

    • Like 1

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Thanks guys, now, another question:

     

    I want the final video to be 1080 x 1080 px, I have made a white cube as canvas which is 30x30x30cm.

     

    How can I lock in the video canvas to the cube? When I go to render preview I get this:

     

    5a5a8a15c901f_ScreenShot2018-01-13at4_36_57PM.thumb.png.23ea0a91fb5900088401c197d5448f8b.png

    Share this post


    Link to post
    Share on other sites

    You need to:

    • Ensure your render settings Output is set to 1080x1080
    • Add a Camera, then under Coord. tab make sure camera position for X & Y = 0 and Rotation HPB are all set to 0 . Set the Z to -20.4cm.
    • Change Sensor Size (Film Gate) to 200mm (under Object tab) so the effective lens is relatively flat.
    • Make sure the Cube is at World 0 and Rotation set to 0.

    You can add a Protection tag to the Camera so it is then locked down and can't accidentally be moved. Right click on Camera, then Cinema 4D Tags>Protection.

     

    That should fill the frame with a 30x30x30cm cube.

     

    If you don't want to use a 200mm lens, you will need to change the Z on the Camera to a different number to fit it to the render area.


    To see what area your camera will render, sometimes it's easy to miss the camera frame border in the viewport. To darken them, go to Options menu (just above Viewport) and select Configure... Change Opacity (next to Tinted Border) to 90% (or to taste). You can change the color of the tinted border next to that as well.

    • Like 1

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Thanks guys, I'm getting there!

     

    Another question :P

     

    For some reason I can't move or rotate certain objects, I can select them and when I use the transform or rotate controls, they move but not the object. Any idea why?

    5a5bd1711fd99_ScreenShot2018-01-14at3_51_57PM.thumb.png.cf4170b32df6d505317fca66a235fe96.png

     

    Share this post


    Link to post
    Share on other sites

    It's too hard to tell from your screenshot.

     

    If those images are in a material, you can't move them as objects unless they're on separate planes (or other geometry).

     

    Can you also explain further what you mean by:

    12 minutes ago, davidgtz said:

    For some reason I can't move or rotate certain objects, I can select them and when I use the transform or rotate controls, they move but not the object.

    That doesn't make sense to me. You say you can't move objects, but then you say they move but not the object? It may have something to do with the Axis of the Object or how you've attached the image to the Cube, but again, it's too hard to tell from the screenshot you've provided.

     

    You may have to upload your scene file to make it easier to help or at least give greater detail on the problem and how you've created the scene.

    • Like 1

    Share this post


    Link to post
    Share on other sites

    All you have to do is switch off the Enable Axis tool. Shortcut is "L", or click the Enable Axis icon shown below in green.

    You are in a mode that moves the Axis of the objects, not the objects themselves.

     

    Axis_Tool.thumb.png.b7d53c1cc0c4178b827970252605bf12.png

    Share this post


    Link to post
    Share on other sites

    I can now see the problem.

     

    You need to temporarily untick Enable on the Cloth tags, move the objects to where you want them, then retick Enable on the Cloth tags. When a Cloth tag is enabled, Cinema 4D is taking control over the placing of the objects as their initial position, that is why it is causing an issue.

     

    You do still need to make sure you don't have Enable Axis on either.

     

    You can highlight them all together so you don't have to do them one at a time.

     

    Cloth_Tag_Enable.thumb.png.23bc49cc6a93c2a77a6624ecb6339635.png

     

     

    • Like 1

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×