Jump to content


Recommended Posts

I am trying to make a wall explode inwards as if it is being detonated from the outside. I have set up voronoi and collider bodies, and am using a keyframed sphere that is hidden as the "explosion". I have used this technique with success before, but now the wall is exploding the wrong direction. It explodes in the same direction the sphere came from. I have messed with every dynamics setting and parameter I can think of, with no success. First of all, how can I fix this. Second of all, is there a better way to simulate an explosion? I want it to start in the center and go outwards like an explosion would... Thanks!

 

https://gyazo.com/81b87b07a954d56415a3dbc1823ccab6

GIF of the error.

Share this post


Link to post
Share on other sites

This is a case where we need the project file to assess the problem properly. Possible issues might be that you have something behind the Voronoi Fracture object that is causing dynamics to cause it to explode backwards, geometry is slightly touching before dynamics is activated that is causing the same problem or a Collision Shape setting is incorrect and causing issues.

Share this post


Link to post
Share on other sites
  • Topic Author
  • 10 minutes ago, ABMotion said:

    This is a case where we need the project file to assess the problem properly. Possible issues might be that you have something behind the Voronoi Fracture object that is causing dynamics to cause it to explode backwards, geometry is slightly touching before dynamics is activated that is causing the same problem or a Collision Shape setting is incorrect and causing issues.

    ahhh I think I might have found it... I believe it was in the collision shape of the wall object. Ill keep playing with it though. In the meantime, is there any better way to simulate an explosion than just a sphere moving into the wall?

     

    Share this post


    Link to post
    Share on other sites
    13 minutes ago, Adept said:

    ahhh I think I might have found it... I believe it was in the collision shape of the wall object.

    That makes sense if the Collision Shape of the area was set to Automatic, then the doorway would not be considered and would makes the pieces blow out backwards as the doorway is effectively not there.

     

    13 minutes ago, Adept said:

    In the meantime, is there any better way to simulate an explosion than just a sphere moving into the wall?

    The way you've done it is fine if you want it to explode inwards into the building. If you want an actual explosion where pieces go in different directions, an alternative would be using one or more Effectors on the Voronoi Fracture such as the Push Apart or Shader Effector and keyframe the Strength/s to get your final look.

    • Like 1

    Share this post


    Link to post
    Share on other sites
    9 minutes ago, Adept said:

    ahhh I think I might have found it... I believe it was in the collision shape of the wall object. Ill keep playing with it though. In the meantime, is there any better way to simulate an explosion than just a sphere moving into the wall?

     

    if you want it to begin at the center and move outwards i'd rather use a cone than a sphere. you could also use an animated a wind object with maybe also a cone shaped falloff.

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • 4 minutes ago, ABMotion said:

    That makes sense if the Collision Shape of the area was set to Automatic, then the doorway would not be considered and would makes the pieces blow out backwards as the doorway is effectively not there.

     

    The way you've done it is fine and is the way I would probably do it if you want it to explode inwards into the building. If you want an actual explosion where pieces go in different directions, an alternative would be using one or more Effectors on the Voronoi Fracture such as the Push Apart or Shader Effector and keyframe the Strength/s to get your

     

    final look.

    Thanks! Its working properly now. One final thing... there is a TON of jitter in the pieces as they go into the room. I tried turning up the steps per frame and max solver iterations/step, but that just made it worse. Is this just a problem I get to deal with with tiny fragments in dynamics in cinema? or is there something else I can do to fix this?

     

    https://gyazo.com/2b5801c257d822e843d81829157109f8

    Share this post


    Link to post
    Share on other sites
    15 minutes ago, Adept said:

    there is a TON of jitter in the pieces as they go into the room. I tried turning up the steps per frame and max solver iterations/step, but that just made it worse.

    That probably means that your dynamics scale is wrong. In project settings / dynamics, try changing that down to 10 cm or even 1 cm.

     

    CBR

    Share this post


    Link to post
    Share on other sites

    If you've already increased the Steps per Frame/Max. Solver Iterations per Step and tried @Cerbera suggestion of changing the Dynamics Scale, other possible things to experiment with on the Voronoi Fracture dynamics tag are as follows. These are just suggestions. Try them one at a time and experiment with the numbers to get the final look you're after. You may need to set a few:

    • Reduce Bounce
    • Increase Friction
    • Use an increased Custom Mass (i.e. 1000)
    • Add small amount of Follow Position (i.e. 0.1)
    • Add small amount of Linear Damping (i.e. 20%)

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • 2 minutes ago, ABMotion said:

    If you've already increased the Steps per Frame/Max. Solver Iterations per Step and tried @Cerbera suggestion of changing the Dynamics Scale, other possible things to experiment with on the Voronoi Fracture dynamics tag are as follows. These are just suggestions. Try them one at a time and experiment with the numbers to get the final look you're after. You may need to set a few:

    • Reduce Bounce
    • Increase Friction
    • Use an increased Custom Mass (i.e. 1000)
    • Add small amount of Follow Position (i.e. 0.1)
    • Add small amount of Linear Damping (i.e. 20%)

     

    2 minutes ago, Cerbera said:

    No, that probably means that your dynamics scale is wrong. In project settings / dynamics, try changing that down to 10 cm or even 1 cm.

     

    CBR

    Unfortunately, both of these helped, but didn't fully fix the problem. I did, however, increase the angular damping from 0-200 after the initial dynamics occur, which fixed it. It might not be perfectly accurate, but it works for the purpose. Thanks for all the help!!

    Share this post


    Link to post
    Share on other sites

    Another way, which can sometimes give a more realistic result than ramping up the angular damping, is to put everything back where you had it, and then just add a particle friction to the scene, which you can keep turning up until it begins to really drain the energy out of the sim. By keyframing its strength over the course of the explosion you can finely control how long the initial energy takes to dissipate.

     

    CBR

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×