Jump to content

Deformed objects not showing in Render


Gilbert

Recommended Posts

Hi

Recently i get an issue with deformers in render:

Object with deformers applied to them are not rendered in the Picture Viewer, but do render in the viewport.

Never happened before.

happens either if the deformer is animated or not.

Solved it by point caching , but that's not a solution .

Any idea what it can be?

 

R18 Studio here.

 

Thanks

 

Gil

 

Link to post

Is it possible to upload your project file or at least a part that demonstrates the problem?

 

My only guess before you provide a file is if you have a project that requires rendering all frames from frame 0 but you are testing, say, just frame 50. It may not be able to calculate the necessary things to render correctly if you don't render it all or cache first.

Link to post

I'll see if i can reduce a file with the problem and upload it.

It Happens even with a simple bend deformer, so caching is a bit of overkill.

Forgot to mention these are animated objects with deformers apllied\ or animated deformers on static objects- both creates the problem.

 

Thanks

Link to post
4 minutes ago, Gilbert said:

its not a matter of layers, happpens in new scene as well.

And it is the object itself that isn't showing in the final render- not the deformers action

 

Hope it's not confusing :)

If you're saying you can create a whole new project, add an object and a deformer (which deformer?) and the object doesn't render, that doesn't really make sense. 

 

It doesn't even make sense when you say the object itself isn't showing, but you seem to say the deformers action is? That doesn't make sense either. How does the deformer working with no object?

Link to post

Let's say i create a cube

Add a bend deformer with animation for the bend

render:  no cube is showing

 

I know it doesn't make sense, that's the thing (should have a tag for that in the forum :)  )

the deformer action isn't showing, because the object isn't showing.

I'll try to recreate the issue and upload.

Thanks ABMotion for taking the time

Link to post
10 minutes ago, Gilbert said:

Let's say i create a cube

Add a bend deformer with animation for the bend

render:  no cube is showing

If you create a new project add a cube with a keyframed (are you just keyframing?) bend deformer and nothing renders, but you can just add a cube and it does render, then I'd suggest either resetting preferences and/or reinstalling Cinema 4D as it sounds like something has become corrupt, assuming that has worked for you in the past. That is obviously very basic and should just work.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

ABOUT US

We are dedicated Cinema 4D Community of friendly and passionate artists, hobbyists and developers. Feel free to join us and share your knowledge, your art and anything that might help Community to grow. We are providing guidance, free plugins and files, feedback, sponsorships and various discounts for our Contributors. :cowboypistol:

SUPPORT

Tickets

Purchases

×
×
  • Create New...

Copyright C4D Cafe © 2020 Powered by Invision Community