Jump to content

rafidola

Bevel Problem

Recommended Posts

Hello.
I have set a selection for a few edges and then I have made a "Bevel" to be the child of the mesh. Then, I put the selection tag in the selection tab of the Bevel but I get some annoying deformation. How do I avoid it?
 

BevelQuestion.jpg

BevelQuestion2.jpg

Share this post


Link to post
Share on other sites

Hard to see what is going wrong here, but I would guess that it's either down to unconnected points, or ngons.

Could you put just that object in a new scene file and upload it ?

 

CBR

Share this post


Link to post
Share on other sites
  • Topic Author
  • 1 hour ago, Cerbera said:

    For the polygon tools like bevel to work properly you need to have geometry that follows polygon rules !

    You have a massive ngon right down the centreline. It can't work with that - you need to run the loops all the way to the center.

    Also make sure you have no stray points - that can also cause this sort of thing.

     

    CBR

    I don't understand. :( What do you mean I have to run the loops all the way to the center and I think I don't have stray points.
     

    Share this post


    Link to post
    Share on other sites

    Yeah I've changed my answer since then - refresh the page ! decided I couldn't see enough of what was going on to be sure of my advice...

     

    CBR

    Share this post


    Link to post
    Share on other sites

    It's because you have 2 coincident points here. Weld those and it should be fine.

     

    5aae786fced44_straypoints.thumb.JPG.25945d5d3235b67adca1e4002af555a9.JPG

     

    Note I have connected the edges across that top bit to minimize the chance of errors caused by that ngon.

     

    CBR

    Share this post


    Link to post
    Share on other sites

    Actually, there are 2 more coincident points above the ones I highlighted initially. You will need to get them all.

     

    CBR

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • 1 hour ago, Cerbera said:

    It's because you have 2 coincident points here. Weld those and it should be fine.

     

    5aae786fced44_straypoints.thumb.JPG.25945d5d3235b67adca1e4002af555a9.JPG

     

    Note I have connected the edges across that top bit to minimize the chance of errors caused by that ngon.

     

    CBR

    I welded the points and then connected the edges on top but still doesn't work correctly.  This is what I get.

    BevelQuestion3.jpg

    Share this post


    Link to post
    Share on other sites

    Look very closely at that vertical. You have a very narrow extra face in there (you have to get in very close to see it). Melt that with the big face to its right, get rid of the two resultant points top and bottom, then add the top line (along the top of the big poly) to your selection. Just done that and it works perfectly.

    Share this post


    Link to post
    Share on other sites

    I don't think you have successfully welded them. When you have it will look like this...

    5aae9498096bb_bevelfix.thumb.JPG.00d3ff69f593c61e1c879e0929f40297.JPG

     

    You are unable to see how many vertices you have selected at the moment because you don't have that information displayed in the HUD. Without that, you are just guessing at what you have selected in circumstances like these...

     

    CBR

     

    Share this post


    Link to post
    Share on other sites

    If you delete neighborrow polygons, you can see just another one, very thin 4sided polygon.Remove it or zoom in close as posible and weld top points and then bottom points.

    thin_polygon.thumb.png.fff1edea653e1189ed1b08e7e669745f.png

     

    or optimize all points with higher value then distance between top/bottom points

    optimize.thumb.png.5fec89164d28890d7463daf9e71695ba.png

    btw, mesh looking so crazy, for me it looks like you are use extrude with enabled cap many times...

    Share this post


    Link to post
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


    • Recently Browsing   0 members

      No registered users viewing this page.

    YOUTUBE CHANNEL:

    ABOUT US:

    C4D Cafe is the largest CINEMA 4D community. We provide facilities for discussion, showcasing and learning our favorite software :)
    ×
    ×
    • Create New...