Jump to content

Sign in to follow this  
ErickM

Sound issues in C4D R19

Recommended Posts

Hello fellow C4D users aka my family,

 

i've got this issue when attempting to play audio within C4D using a Mograph sound effector. My sample rate is 41K Hz, it's a tiny file of maybe 1.8mb. 

My scene has a model that i would like to sync-animate to the audio. However, i'm getting these "skips" every now and then, random skips like a broken record.

 

Here's what i tried:

1. Lowering my bitrate from 24bit to 16bit 

2. Changed from mp3 to aif file

3. Changed from aif to wav file 

4. Deleted all unnecessary textures and objects and stuff

 

My first instinct is that my Imac can't handle it. I mean it's a 2015 stock 13 inch, 8gig ram with a 2.6 GHz Intel Core i5 (i guess that sucks)

Well although it's an unfortunate situation, i was hoping that maybe someone (a hero) can suggest a working a work-around this? 8) 

 

In conclusion, i'm going to have to go "old school". I'll determine the BPM of the song and calculate the frame rate and animate without audio (yikes). Technically that should work but i don't know. I will post the results in hope to help someone else who may have the same issues in the future.  Cheers!

Share this post


Link to post
Share on other sites

Could you post the scene and the sound file (16 bit mp3) pls ?

 

CBR

Share this post


Link to post
Share on other sites

Does the sound play OK with no animation? My guess is that the animation is not running at project speed. You might try unchecking 'all frames' in the little filmstrip thing lower R of the viewport. I don't use it myself, but help says 'If selected, all frames of a given animation will be shown. Normally, if a computer is not fast enough, frames will be omitted when an animation is played in order to be able to reflect the frame rate defined in the Project Settings'.

 

Are you actually using sound effector to drive stuff ? You can also play sound by using 'create, add special track, sound' to say a null in the timeline.

 

 

 

Share this post


Link to post
Share on other sites
  • Topic Author
  • 3 hours ago, jed said:

    Does the sound play OK with no animation? My guess is that the animation is not running at project speed. You might try unchecking 'all frames' in the little filmstrip thing lower R of the viewport. I don't use it myself, but help says 'If selected, all frames of a given animation will be shown. Normally, if a computer is not fast enough, frames will be omitted when an animation is played in order to be able to reflect the frame rate defined in the Project Settings'.

     

    Are you actually using sound effector to drive stuff ? You can also play sound by using 'create, add special track, sound' to say a null in the timeline.

     

     

     

    @jed I tried playing audio in a blank scene, utilizing only the Mograph sound effector and it plays throughout with minor skipping occurrence. 

    The little filmstrip thing  says all frames are selected. I think you're right, when playing without automation, the "frame rate" seem to be going pretty fast or rather at normal speed and as soon as i add animation keyframe, it slows down a bit. I'm not using sound effector to drive stuff.  I didn't know i can use a null to play sound, i will give it a try. Thanks for all the suggestions :)

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • 3 hours ago, jed said:

    Does the sound play OK with no animation? My guess is that the animation is not running at project speed. You might try unchecking 'all frames' in the little filmstrip thing lower R of the viewport. I don't use it myself, but help says 'If selected, all frames of a given animation will be shown. Normally, if a computer is not fast enough, frames will be omitted when an animation is played in order to be able to reflect the frame rate defined in the Project Settings'.

     

    Are you actually using sound effector to drive stuff ? You can also play sound by using 'create, add special track, sound' to say a null in the timeline.

     

     

     

    @Cerbera i will try @jed's suggestions and if all fails, i'll upload the files so you can have a look in hope that you can help me troubleshoot the problem. 

    Thank you.

    Share this post


    Link to post
    Share on other sites

    I was also going to suggest the all-frames thing, but actually recommend the opposite, that you actually turn it on if it isn't already !

    I'm working on the principle that if you playback every frame (and your computer can cope) then the audio has the best chance of syncing to those frames and playing back uninterrupted. I suspect that if frames are being skipped in order to get smooth viewport playback, then it stands to reason that the audio will skip too, hence you should have that setting on.

     

    What do you reckon, @jed?

     

    CBR

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • 15 minutes ago, Cerbera said:

    I was also going to suggest the all-frames thing, but actually recommend the opposite, that you actually turn it on if it isn't already !

    I'm working on the principle that if you playback every frame (and your computer can cope) then the audio has the best chance of syncing to those frames and playing back uninterrupted. I suspect that if frames are being skipped in order to get smooth viewport playback, then it stands to reason that the audio will skip too, hence you should have that setting on.

     

    What do you reckon, @jed?

     

    CBR

    I double checked to make sure "all frames" were being played back in the viewport, thus supporting your point @Cerbera and i still get the "skips" at the same location in the audio file. Is it safe to assume that my computer cannot cope?

    Share this post


    Link to post
    Share on other sites
    Just now, ErickM said:

    Is it safe to assume that my computer cannot cope?

    You see I find it very difficult to accept that any vaguely modern computer can have problems playing back a tiny wav or mp3 file, even if there is other stuff going on too :) I asked for the files simply so I could see what playback was like for me so we could determine if there was anything wrong with the audio file or format.

     

    But if you are getting the skipping, I'm really not sure what other setting we could change to improve things :/

     

    Having said that, the old school way of working out the BPM and doing it with timing alone is a totally viable method that served us all for years before things like Cinema came along, so at least you have other options, hey ?

     

    CBR

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • 1 minute ago, Cerbera said:

    I asked for the files simply so I could see what playback was like for me so we could determine if there was anything wrong with the audio file or format.

     

     

    How do i upload files? Can i use dropbox and paste the link here?

    Share this post


    Link to post
    Share on other sites
    2 minutes ago, ErickM said:

     

    How do i upload files? Can i use dropbox and paste the link here?

    You certainly can. Or upload file directly here if it is small enough... when you post there is an option to attach stuff...

     

    CBR

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • 8 minutes ago, Cerbera said:

    You certainly can. Or upload file directly here if it is small enough... when you post there is an option to attach stuff...

     

    CBR

    Alright, here's the link to DB:

     

    https://www.dropbox.com/sh/epfe00wtwx34vd9/AABBoYuRsaIB77qVxckl7Zbza?dl=0

     

    Unfortunately, the file is larger than "allowed" size (~30mb)

    Share this post


    Link to post
    Share on other sites

    You didn't tell me this was butt -wiggling :)

     

    Ok, it does exactly the same for me as you are getting, regardless of the All frames setting, and I have a pretty decent PC. So it's not a performance thing.

    I suggest you take this straight to MAXON and ask them, because at the moment, that's looking awfully like a bug !

     

    CBR

    Share this post


    Link to post
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×
    ×
    • Create New...