Jump to content

Sign in to follow this  
ninjad

Redshift Skin Material

Recommended Posts

I'm new to Redshift and I'm trying to figure out how to do a skin material that has a diffuse, specular, bump, displacement & sub-surface map.

 

I'm able to get the diffuse, spec, bump, and displacement maps layered together in a basic material, but I can't figure out how SSS fits into the output.

 

When I look at an example RS SSS/Skin material, I see an SSS/Skin node directly linked to the Surface port of the Output node. How are you supposed to use it in conjunction with a regular RS Material node if it also needs to connect to the Surface port?

 

I noticed the Multi-SSS input ports in the RS Material node, but when I try and feed the Out Color of an RS SSS node to an Ms Color port the material goes black.

Share this post


Link to post
Share on other sites

  • Topic Author
  • Actually I think I might have gotten it.

     

    In the RS Material node, under the Multi-SSS tab, I turned up the amount, then added an Ms Color port and fed the SSS map into it.

     

    My mistake was adding an SSS node in between the texture map and the Ms Color port.

     

    If anybody has any input feel free.

     

    Also while I'm on the topic, if anyone can explain the difference between an SSS node, Skin node, and using Multi-SSS in the Material node that would be helpful.

    Share this post


    Link to post
    Share on other sites

    Hi there Ninjad,

     

    I've been using Redshift since August last year, I'm far from an expert but have slowly managed to build up an understanding of the shaders. I understand your questions as I also had the exact same ones a few months ago.

     

    Firstly the difference between the 3 SSS nodes.

     

    The SSS nodes and Skin nodes are legacy shaders. That is to say, early on in Redshifts development the SSS node was the only Subsurface scattering node available. Then they created a SSS Skin node to better emulate the different layers of skin. This was a little difficult to use for some users. 

     

    Then came the 'Uber shader' the RS Material. This material contained the Mult-SSS ability to make it easier to use SSS. From the Redshift forums, the developers recommend you use the multi-SSS in the RS material unless you are a bit of an expert and want more control (then use the other nodes)

     

    A skin material can be created with the RS material using the method you eventually found out. crank up the SSS amount to 1, the radius can go way higher than the slider makes it seem if the SSS effect isn't enough. You can also plug in images to the 3 SSS colour layers. 

     

    Good luck!

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Thanks for the info! Yea, I actually just dug into the manual a little further today.

     

    Ironically as soon as I absorbed everything and got a handle on all the settings, multi-sss in the material node stopped working for some reason. I've been trying to figure it out all day.

     

    I feel like it was working yesterday, but then today I noticed it wasn't doing anything on the renders anymore and when I tried starting a new file from scratch there's no effect.

     

    The Sub-Surface settings in the Base Properties works fine, but no matter what I do in the Multi-SSS panel nothing happens. When I set the amount to 1, turn up the layer weights, and crank up the radius, Nothing!

     

    Have you come across this at all? I'm hoping there's just some dumb setting I'm overlooking.

    Share this post


    Link to post
    Share on other sites

    remember that multi SSS only works in bucket mode, make sure you've unchecked 'Force IPR' in the render settings.

     

    That being said the latest version of Redshift has multi SSS that does work in bucket mode - you have to crank up the samples though as it's quite noisy. You will know if you have this setting, I reckon you've set it to progressive mode when it needs to be bucket ;)

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • That was it! Oh man, I was messing around with so many settings I forgot about that. It was like something nagging at the back of my head that I knew I had forgotten.

     

    Thanks! :oregonian_winesmiley:

    Share this post


    Link to post
    Share on other sites

    No problem, happy to help!

    Share this post


    Link to post
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×
    ×
    • Create New...