Jump to content


Sign in to follow this  
sneather

Can't Add Material to Bevel on Boole...

Recommended Posts

sneather    1

Please see the attached file. I need to make an animatable boolean object, but something in this combination of settings is NOT allowing any material to apply to the active bevel. Can someone please take a look and let me know what I can do?

 

Thanks!

boole bevel material issue.c4d.zip

Share this post


Link to post
Share on other sites

Cerbera    1,815

There you go... just gotta have the right materials on the right things :)

 

boole bevel material issue fixed.c4d

 

CBR

 

PS: The Connect Object I have inadvertently left in your file is superfluous to requirements, so you can pop that in the bin :)

Share this post


Link to post
Share on other sites
sneather    1
  • Topic Author
  • Hey, thanks for taking this on! However, when I open your project, the bevels are still not materialized (see screen cap).

    I'm able to get the material on the flat sec ion of the boole cut, however, it's the actual bevels which refuse to accept a material, once another is applied to one of the component objects inside the boole. Did it not look like my attached image, on your end? I get the same result in both my versions of R17 & R19...

     

     

    bevel material issues.jpg

    Share this post


    Link to post
    Share on other sites
    Cerbera    1,815

    Oh no I'm not getting that. I'm getting this...

     

    boolebeveltex.thumb.PNG.b200bf6a371981ff151e0e24268bf535.PNG

     

    I wonder what the difference could be ? Bit mystified on that one :/

     

    CBR

    Share this post


    Link to post
    Share on other sites
    sneather    1
  • Topic Author
  • 4 minutes ago, Cerbera said:

    Oh no I'm not getting that. I'm getting this...

     

    boolebeveltex.thumb.PNG.b200bf6a371981ff151e0e24268bf535.PNG

     

    I wonder what the difference could be ? Bit mystified on that one :/

     

    CBR

    Oh, yikes. That's not good. What in the world would cause such a clear difference? 

    Share this post


    Link to post
    Share on other sites
    Cerbera    1,815

    We're both on 19.053... I'm on a Win 7 PC though - what about you ? Not that this should make the slightest difference, but grasping at straws here - VERY rare that the same file opens differently in different locations !

     

    CBR

    Share this post


    Link to post
    Share on other sites
    sneather    1
  • Topic Author
  • Okay, so I had tried MY original example project in both R17 & R19 - and the results had been the same.

    But I only tried YOUR fix in R17. So I just tried it in R19, and it looks like yours! 

    I'm going to have to open your file in both versions, simultaneously, and scrutinize the exact differences.

    Share this post


    Link to post
    Share on other sites
    sneather    1
  • Topic Author
  • 3 minutes ago, Cerbera said:

    We're both on 19.053... I'm on a Win 7 PC though - what about you ?

     

    CBR

    My R19 Studio is the current .053 build. I'm Mac 10.9.5.

    Share this post


    Link to post
    Share on other sites
    sneather    1
  • Topic Author
  • It's odd that there would be a difference even down in R17. I can't find any mention of changes to the boole nor bevel deformer in either R18 or R19. The options for both seem to be identical in R17 & R19. But who knows what may have been tweaked in the intervening years...

    Share this post


    Link to post
    Share on other sites
    Cerbera    1,815

    Yeah - I'm also not aware of any changes to that between 17 and 19... but glad you got it working in the end...

     

    CBR

    Share this post


    Link to post
    Share on other sites
    deck    53

    Hi Guys

    Out of interest that doesn't work for me either, Im on R18 on a mac 10.11.6.  Some retouching to do today but will have a tinker with it later to see if I can sort it for my own satisfaction.

    Deck

     

    Screen Shot 2018-05-17 at 08.05.24.png

    Share this post


    Link to post
    Share on other sites
    sneather    1
  • Topic Author
  • Interesting. Thanks, for also having a look. Keep us posted, when you get time to investigate further.

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×