Jump to content


flyingllama

Knife Tool Doesn't Work

Recommended Posts

flyingllama    0

Hi guys, I'm trying to create a mouth of the character by using a knife tool.

But, it doesn't cut anything on the object after dragging the knife tool like the picture below, or only makes a cut in random places.

 

I tried polygon, point, edge mode when I cut them, they all don't work.

 

I made the object by extruding the spline and now it's the polygon object. 

 

I made another cube to test it, it cuts right in the cube.

 

How come it's not cutting the object and how could I fix it?

 

Thank you of your help.

 

 

del2.png

Edited by Cerbera
Capitals in titles please !

Share this post


Link to post
Share on other sites

deck    65

It may be that you have extruded as separate objects, i.e. the caps top and bottom are separate and you are currently just cutting through the edge bit.

So you can either cut the cap assuming it is separate. Or you can optimise the model which should weld it all together. you should be aware also that your caps are probably two big Ngons who's lines are hidden, you can show them in the filter menu, this may also cause you problems.

You may wish to redo it from the extrusion and change your settings in caps and set to create single object.

 

However, if you are thinking of animating / bending or anything like that with your toast those ngons will cause problems. Im not an expert  but I think most members would advice modelling it properly with box modelling and subdivision.

 

Some grabs below to try and illustrate, is your toast like the extrude below with 3 separate parts ? Need to post a file to be sure as i could be wrong.

 

Deck

 

Screen Shot 2018-06-13 at 12.48.31.png

Screen Shot 2018-06-13 at 12.49.24.png

Screen Shot 2018-06-13 at 12.49.40.png

  • Like 1

Share this post


Link to post
Share on other sites
Cerbera    1,898

You have 18.39, which has known knife tool problems. Update to latest version of R18, and that will get solved.

 

CBR

Share this post


Link to post
Share on other sites
flyingllama    0
  • Topic Author
  • 3 hours ago, deck said:

     

    Here I attached what it looks like. I opened the toast in the new file, it seems that it cuts the side

    now, so I'm not sure if that was an error or something I did wrong.

     

    If I were to animate the toast, do you mean it would have been better if I started with the cube

    rather than extruding the spline?

     

     

     

     

     

    3 hours ago, deck said:

     

     

     

     

     

     

     

     

     

     

     

     

     

     

    It may be that you have extruded as separate objects, i.e. the caps top and bottom are separate and you are currently just cutting through the edge bit.

    So you can either cut the cap assuming it is separate. Or you can optimise the model which should weld it all together. you should be aware also that your caps are probably two big Ngons who's lines are hidden, you can show them in the filter menu, this may also cause you problems.

    You may wish to redo it from the extrusion and change your settings in caps and set to create single object.

     

    However, if you are thinking of animating / bending or anything like that with your toast those ngons will cause problems. Im not an expert  but I think most members would advice modelling it properly with box modelling and subdivision.

     

    Some grabs below to try and illustrate, is your toast like the extrude below with 3 separate parts ? Need to post a file to be sure as i could be wrong.

     

    Deck

     

    Screen Shot 2018-06-13 at 12.48.31.png

    Screen Shot 2018-06-13 at 12.49.24.png

    Screen Shot 2018-06-13 at 12.49.40.png

    dell_01.JPG

    Share this post


    Link to post
    Share on other sites
    deck    65

    Thats kind of what Im saying yes. tho you could improve your current result by going back and changing the cap segments to quadrangles, which helps and could work but is not ideal.

    When you animate / bend / distort your mesh it will only do so along the lines you have in your mesh, so it will try and bend along those green lines.

    Once done as proper modelling you could also go in and sculpt a few lumps and bumps on the edges which wouldn't work with your current mesh.

    Your ngon lines aren't currently showing in your latest grab

    Deck

    Share this post


    Link to post
    Share on other sites
    flyingllama    0
  • Topic Author
  • 10 hours ago, deck said:

    Thats kind of what Im saying yes. tho you could improve your current result by going back and changing the cap segments to quadrangles, which helps and could work but is not ideal.

    When you animate / bend / distort your mesh it will only do so along the lines you have in your mesh, so it will try and bend along those green lines.

    Once done as proper modelling you could also go in and sculpt a few lumps and bumps on the edges which wouldn't work with your current mesh.

    Your ngon lines aren't currently showing in your latest grab

    Deck

    Yeah, I tried to put subdivision in the extruded object, it goes crazy. I should have started with the cube. Okay, I will try to do that. This helped a lot! Thank you very much for your reply and help. :)

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×