Jump to content

Sign in to follow this  
cakebiter

Displacer Not Working in Emulation Mode

Recommended Posts

I have two materials on a plane.  One is a texture with nothing but sub-polygon displacement, the other is a texture for color.  The displacement texture is applied to the plane first.  The color texture is added with "Mix Texture" checked.  I then put a Displacement Deformer under the plane in Emulation mode.

 

On my home computer it works as expected.  The plane is deformed in the viewport and colored with the color texture.  But on my work computer, the displacement texture is completely ignored.  What's going on here?  Is there a setting I don't know about?

 

I should note that this problem doesn't affect the render.  It is purely a viewport issue.

  

LoneTreeHill_v02_QUESTION.c4d

Share this post


Link to post
Share on other sites

Your scene contain also link to *.png file. If you didn´t tranfer c4d file together with this png image, c4d "don´t see" this file.

Texture files are not "embedded" into c4d file, need to copy them manually.

If you transfer also this png image, maybe needed relink this image. (Don´t know if was used relative or absolute paths in original file)

Best way to transfer complet scene files is saving as projects. This way is scene saved completely with all textures (TEX folder next scene file) and could be transferred as single folder/zipped file/stored on cloud etc...

Share this post


Link to post
Share on other sites

As soon as you render it, the displacer in emulation mode is turned off and what you see is just the material displacement.

 

Are you maybe on 2 different versions? Material layering for the emulation mode was broken and I fixed it for R19 SP2.

Share this post


Link to post
Share on other sites

Whoops, I forgot to include the .png file.  It's too big to upload, but I think I found the answer:

1 hour ago, Fritz said:

Material layering for the emulation mode was broken and I fixed it for R19 SP2.

 

This could explain my problem.  Maybe the Displacement Deformer doesn't see there are two textures on my plane due to a bug.  

 

I'm in version R19.053.  I checked for updates but there don't seem to be any.  Is this just a bug I have to work around?

Share this post


Link to post
Share on other sites

That is R19 SP2. Do you use the same version on your work computer?

Can you post a simplified scene? I could then have a look on Monday if I can reproduce it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

YOUTUBE CHANNEL:

ABOUT US:

C4D Cafe is the largest CINEMA 4D community. We provide facilities for discussion, showcasing and learning our favorite software :) Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, get your own private messenger, post status updates, manage your profile and much more. If you need to find solution to your problem or otherwise ask for help, Cafe is the right place.
×
×
  • Create New...