Jump to content

Sign in to follow this  
bentway

Animation copying/pasting to wrong time

Recommended Posts

Stupid question du jour . . . . In a nutshell, when I copy a character from one file to another the first 2,000 frames of her animation aren't copying, they just disappear.

 

I'm on a project that has a 4,000+-frame mocap track, parts of which are being used by different scenes. I'm working on the segment that uses frames 0 - 2,000. The final mocap was cleaned up for the segment using frame 2,200 - end. (Although the whole range was cleaned up, that was just the file in which they were doing the cleanup.)

 

I have to bring in the final cleaned animation (from the entire sequence, but focused on frames 2,200-on) into the file I had been working on (fr 0 - 2,000). Other than the nudging necessary for cleanup, the mocap in the new and old scenes still match--frame 652 in the first still corresponds with frame 652 in the cleaned up (and 350 = 350, 1,100 = 1,100, etc.) for instance. However, when I copy the character from the cleaned up file and paste her into my working file, the pasted version doesn't copy the first 2K-odd frames--it just starts where that new section starts, so the new character on my frame 2 is doing what she was doing at frame 2,002 (or so) in the file I was copying from.

 

Any idea how I can get the new character to copy cleanly into the old file, so the timeline doesn't lose 2,000 frames?

 

I edited the render settings in the new file to match the old (fr 0 - 2,000). I even tried moving the copied version around in the dope sheet on the old file, but those 2000 frames just don't exist--it's not like they're hiding before the 0 and I can just slide them.

 

The only weirdness with the new file (which I don't think should make a difference here) is that the render resolution and aspect ratio were different. It was also 29.97 fps instead of 30, but I tried it both changing that and not changing that to no avail.

 

I'm sure there's an obvious setting somewhere I'm missing. Thanks for any help.

 

Share this post


Link to post
Share on other sites

  • Topic Author
  • Epiphany right after posting, putting up my successful resolution in case anyone else runs into this--

     

    I went to the new/cleaned up scene, deleted everything except the character, and saved it as a new file. I went into my project file and did a Merge Object. I thought that worked the same as copy/paste, but apparently it will succeed where c/p fails.

    Share this post


    Link to post
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    YOUTUBE CHANNEL:

    ABOUT US:

    C4D Cafe is the largest CINEMA 4D community. We provide facilities for discussion, showcasing and learning our favorite software :)
    ×
    ×
    • Create New...