Jump to content

Dannyx

Area light making scene turn white

Recommended Posts

Good day folks. I just came back to a project I had been working on for a long time now, being a beginner and all and it's done now and ready to render, but I've ran into an issue, which it HAS done before but never actually found a cure: sometimes, and this is the key word here, SOMETIMES when I do a render, the scene comes out all white, like a very bright light is overtaking everything...other time it's fine. It seems to be totally random: sometimes I exit the program, launch the scene again and it's fine. Other times I have to restart the computer and it's fine, other time neither of these work.

I tracked it down to a light causing this: it's a white area light set to "shadow maps" and sure enough, when I hit "render", the status bar says "rendering shadow maps". Takes about 30s, my rig not being really up to the task of running C4D, but we make due with what we have.

If I disable this particular light, no problem: instant rendering (no more "rendering SM" message) and the colors and tones all look like they should. Trouble is I kinda need this light to make things look good, so I can't just delete it. There are other lights in my project and they too are set to "Shadow maps soft", so what's special about this one causing the scene to mess up ? Another aspect that might be of interest is cloning: I'm cloning this light to create several ceiling-type lamps sort-of deals - will probably get a lot of hate for breaking some taboo C4D rule about cloning lights :))

It did this a couple of times when I was building the scene too, but I overlooked it thinking it would go away before the final render, but it doesn't - at least not always. GI is not ticked in render settings - looks very good WITH it, but the time it takes to render is very long for my PC, so I dropped it. It's not related to this, since I tried it both with and without it and the results are equally as sporadic...

What would (generally) cause this ?

Share this post


Link to post
Share on other sites

Rendering shadow maps is gonna happen any time you use shadow map lights and render the scene, we can't avoid it.  But soft shadows are designed primarily for omni and spotlights. But if you are going to the trouble of using an area light, you'll get nicest results using area shadows... takes a bit longer, but probably not that much because there is no shadow map to be calculated !

 

CBR

Share this post


Link to post
Share on other sites
  • Topic Author
  • Switched over to "Area" shadow just to see what happens (again, I'm a beginner at this stuff and have no idea what most of these setting do by name...practice, practice, practice...), and I haven't noticed anything "off" so far. Still looks OK and hey, no more white stuff :) It sometimes went away after disabling and re-enabling the light object itself - I just remembered that's how I tricked it into playing along.

     

    EDIT: VERY slow with area shadows - I rushed into typing the reply without waiting for the whole frame to render and I noticed it was still going...

    Share this post


    Link to post
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


    • Recently Browsing   0 members

      No registered users viewing this page.

    YOUTUBE CHANNEL:

    ABOUT US:

    C4D Cafe is the largest CINEMA 4D community. We provide facilities for discussion, showcasing and learning our favorite software :)
    ×
    ×
    • Create New...