Jump to content

basvanbergen

Not able to set translation keyframes

Recommended Posts

Hi!

 

I've got a controller (curve object) taken from the standard C4D character rig. But I seem unable to keyframe the translation. I've singled out the curve and removed all tags and layers to no avail

The weird thing is, I can animate the position in the Attributes->Coord. 

It's just that the 'record active objects' and the 'Auto Keying' buttons have no effect.

 

I think there might be some unseeable python code still stuck on the object or something lake that.

 

Ive Attached the file if someone is curious (try to set a position keyframe with the keyframe button)

 

I hope someone knows a solution

weird_non_keyable_translation.c4d

Share this post


Link to post
Share on other sites

the rotation parameters are coloured orange. that's probably because the original purpose of this controller was to rotate only. orange means there was a keyframe selection set for these parameters. so either select the rotation parameters, right click and choose "animation">>"remove keyframe selection" or select the position parameters and choose "set keyframe selection"... then the position parameters will also be taken into account.

Share this post


Link to post
Share on other sites

Hi Everfresh, thanks for the reply... I contacted MAXON, it turns out to be a bug. 

 

Here is their reply:

the development confirmed the behaviour as a bug. Now the developer has to find a fix for the issue, so it will work correctly in one of the coming versions. Unfortunately at time, you will have to animate these parameters manually.

 

Tomorrow I’ll try your workaround and see if that works... In the meantime I circumvented the issue by creating my own controllercurvers... Thanks for lookin into this though..

 

All the best!

 

Bas

 

Share this post


Link to post
Share on other sites

It's not a bug. MAXON has incorrectly classified it as a bug. It is as everfresh said. When they are colored orange, they are part of a keyframe selection and the Record Active Objects button respects those selections. But the Attribute Manager is allowed to overwrite that manually. 

Share this post


Link to post
Share on other sites

Sorry for the late reply again. You guys are absolutely right! Didn't know about these keyframe selections, which are actualy quite handy. Thanks for looking into this, and I've informed MAXON.

 

Thanks again!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

YOUTUBE CHANNEL:

ABOUT US:

C4D Cafe is the largest CINEMA 4D community. We provide facilities for discussion, showcasing and learning our favorite software :) Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, get your own private messenger, post status updates, manage your profile and much more. If you need to find solution to your problem or otherwise ask for help, Cafe is the right place.
×
×
  • Create New...