Jump to content

danradio

Invisible triangle

Recommended Posts

Hi, I'm having a strange problem. I've modeled a head by cutting up a cube but, even though the viewport shows a flat plane, the render shows some additional triangles. I've gone to the Structure Manager and I don't have a fifth column, so I know there aren't any n-gons.  I've also intentionally removed the phong tag.

 

How do I get rid of these invisible triangles? 

 

Thanks!

Screen Shot 2018-08-08 at 1.25.57 PM.png

Screen Shot 2018-08-08 at 1.26.11 PM.png

Share this post


Link to post
Share on other sites

It's probably because you have some quads that are so distorted that they aren't flat anymore.  Without any phong, they will look like 2 triangles.  If you throw this in a SubD they should go away.

Share this post


Link to post
Share on other sites

...we could say you have non-planar polygons...

  • Like 1

Share this post


Link to post
Share on other sites

@bezo, I'm no expert at modeling- is this a "no no?"  Or mostly fine if you're subdividing it anyway?

Share this post


Link to post
Share on other sites
  • Topic Author
  • Ah ok, I'm new to all of this, especially modeling.  I want to keep the face geometric, so I'm not going to subdivide it.

     

    I'm going to have to research this non-planar thing.

     

    Thanks for the help!

    Share this post


    Link to post
    Share on other sites

    I don´t say "no no" :D

    It´s just note. When he enable in Attr. Manager/Mode/Modeling/Mesh Checking, those polygons with triangles would be marked as non-planar...

    • Like 1

    Share this post


    Link to post
    Share on other sites
    10 hours ago, bezo said:

    When he enable in Attr. Manager/Mode/Modeling/Mesh Checking, those polygons with triangles would be marked as non-planar...

     

    I'm interested in this

    how do I get there?

    is this in Studio only or for all versions ?

     

     

    EDIT:

    yeah, found it :Zap:

    Share this post


    Link to post
    Share on other sites
    15 hours ago, danradio said:

    Ah ok, I'm new to all of this, especially modeling.  I want to keep the face geometric, so I'm not going to subdivide it.

    Oh, then you can simply select the non-planar polygons one-by-one and scale it to zero on the Z axis.  Be sure you are in local mode and hold shift while scaling to snap by 10% increments.  It's possible that this would cause other polys to become non-planar, so it may be a case of fixing all the surrounding polys as well.  Maybe there is a way to do this to all polygons simultaneously?  Can't think of a way...

    In the future, if you're modeling with quads for a low-poly look, then you will want to be in Polygon mode when you're editing your mesh.  Or you could just use triangles, which sometimes look better for low-poly stuff (and can't be non-planar).

    • Like 1

    Share this post


    Link to post
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


    • Recently Browsing   0 members

      No registered users viewing this page.

    YOUTUBE CHANNEL:

    ABOUT US:

    C4D Cafe is the largest CINEMA 4D community. We provide facilities for discussion, showcasing and learning our favorite software :)
    ×
    ×
    • Create New...