Jump to content

Sign in to follow this  
thanulee

Displacer doesnt match my color

Recommended Posts

Hi, i use a noise to drive a displacer but the displacer is different than the color channel, like it has different uvs or something. Any thoughts?
Here is scene file:

https://www.dropbox.com/s/yryd4j5fys3jjlv/displacer match problem.c4d?dl=0

thanks !

Share this post


Link to post

Hi thanulee,
Are you using octane render engine Or C4D standard renderer ? because your scene have an octane render setting with standard C4D material....

Share this post


Link to post
  • Topic Author
  • Hello, i use octane in general. But without rendering if u see in the viewport the standard c4d mat doesnt match the displacement as well

     

    Share this post


    Link to post

    Seems kind of as I would expect in my viewport, or maybe Im missing something.

     

    Deck

     

    Screen Shot 2018-08-21 at 12.32.33.png

    Share this post


    Link to post
  • Topic Author
  • Oh... this is really weird... here i see something else on the material and something else on the displacement.. Thanks for the info though
    edit: ur right, the material preview in viewport is wrong , on render is ok! Is that fixable? ty

     

    Share this post


    Link to post

    It is all a bit weird as i don't get any viewport render in your file, but if I copy and paste into new file it seems completely different. Dunno if it makes any difference but I don't think you need the texture on the displacer, you just drag the texture on the plain into the displacer field, I think :)

     

    deck

    Share this post


    Link to post
  • Topic Author
  • Press NQ and u ll see viewport preview on the plane. Is it correct?

    Share this post


    Link to post

    Ah, no textures. No the viewport display doesn't look right, but Im not sure any of the noises display properly in the viewport, don't think Ive ever been able to do that. Most annoyingly with the wood shader.

     

    Deck

     

     

    Share this post


    Link to post

    Think I've got it, and really useful for me too.

     

    In the options menu of the viewport there is a box for noises, turn that one on and it all looks as it should, time to give that wood shader another try.

     

    Deck

    Screen Shot 2018-08-21 at 14.20.58.png

    Share this post


    Link to post
  • Topic Author
  • Thanks mate, also i spoke with octane dev in anyone interested, noise has to be on UV (2d) mode so they match :) cheers

     

    Share this post


    Link to post

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×
    ×
    • Create New...