Jump to content


asiejenski

Compositing tag

Recommended Posts

Hi
I have a problem with the compositing tag.
The background image is on the Background. The same image on Plane with Compositing Background marked in Compositing Tag. All lighted HDRI (on the Luminance layer, no other changes) on Sky Object.
Global Illumination and Ambient Occlusion included.
As you can see in the picture, Plane is brighter.

compositing_tag.jpg

Share this post


Link to post
Share on other sites

I've seen many posts with this issue and no one ever really had a fix or explanation, so I've spent a bit of time trying to figure this out.

 

The problem goes away when Linear Workflow is turned off in the Project Settings, but then that wrecks the HDR lighting on the sphere object! What seems to be happening is that the plane shows shadows being generated by the HDR illumination, which includes some color, however the Background object is not affected by the HDR so we see this mismatch.

 

The color and brightness info in HDR spoils the way the texture gets lit on the plane (can't have shadows without light). I made some adjustments to your HDR material to compensate. File attached at the very bottom.

 

Oddly enough, this works without a comp tag on the plane. :)

 

 

vizn_compositing_tag.jpg

Screen Shot 2018-10-11 at 4.34.29 PM.png

Vizn_compositing_tag_Main.c4d

Share this post


Link to post
Share on other sites
52 minutes ago, Emir said:

You need to put your Plane's  image on the luminance channel and turn off the color channel.

 

Good Luck

This is all wrong. Luminance on the plane negates the shadow! Plus, why is the sphere glowing like the sun?? 

Share this post


Link to post
Share on other sites

My apologies if my answer bothers you, i was trying to answer the main question. 

 

The glow is because of a quick HDRI that i used for a quick render test.

 

Again, sorry for the inconvenience.

 

Good Luck with your project

Share this post


Link to post
Share on other sites
  • Topic Author
  • 10 hours ago, Vizn said:

    I've seen many posts with this issue and no one ever really had a fix or explanation, so I've spent a bit of time trying to figure this out.

     

    The problem goes away when Linear Workflow is turned off in the Project Settings, but then that wrecks the HDR lighting on the sphere object! What seems to be happening is that the plane shows shadows being generated by the HDR illumination, which includes some color, however the Background object is not affected by the HDR so we see this mismatch.

     

    The color and brightness info in HDR spoils the way the texture gets lit on the plane (can't have shadows without light). I made some adjustments to your HDR material to compensate. File attached at the very bottom.

     

    Oddly enough, this works without a comp tag on the plane. :)

    Thanks :)

    The odd is that it works only without comp tag or with Compositing Tag unchecked.

     

    Theoretically works but I can't increase the HDRI light (I do it by increasing texture exposure, or maybe is other way to do it without adding Light Object?).

     

    And the same problem is when I use only HDRI as light and background (without another Background with texture). Plane has checked Compositig Background for HDR Map. Unfortunately, your solution did not work in this case.

     

    compositing_tag_HDRI.thumb.jpg.67c2eedae8d66b7b7a5e5cc8c184feed.jpg

     

    @Emir
    When I change for luminance channel I will lose the shadow.

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×