Jump to content

Janis Lanka

Symmetry Not Working With Dynamics

Recommended Posts

Hello,

 

I am trying to model a turret with two cannons attached(R18.057). The cannons are in Symmetry and, to make them rotate in a realistic Fashion, i have added a Motor,  Connector and two Ridged Bodys. The set up is working in my Viewport. That is when i view the Animation the cannons are rotating. Now i tried to render the Animation out, but in the final render the Canons are no longer rotating. After quite some Exploration i found out that, if i disable the Symmetry-Object, with the same Settings and Dynamics attached as before, and render, the Motor/Dynamics/Roation will work in the final render aswell.
So, why is it that the Symmetry-Object hinders the Dynamics from actually Rendering? No matter the render engine. My Project and Render Settings match (at least i think so.. ). I have cleared and backed the Cache(s) of the Dynamics Tags.
I could just convert the Symmetry to Geometry, but that would suck. So i hoped there is a work around to this Problem. Mybe the issue has been solved in later versions of cinema?

 

Cheers

Share this post


Link to post
Share on other sites

Its hard to tell like this. Sharing a scene file could help to resolve your issue.

Share this post


Link to post
Share on other sites
  • Topic Author
  • Here is a example Scene with the minimal Setup to visualize the Problem. Playing the Animation in Viewport works fine. Now Go to Picture Viewer and you will see the example objects not moving. ***.

     

    PS. Delete the Cache and the Platinics are going to even fall down..

    dynamics_bug_file.c4d

    Share this post


    Link to post
    Share on other sites

    Does your scene actually need dynamics ? Regular keyframing works OK with symmetry (and renders).

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Well it would be more realistic with Dynamics of course. I could use keyframing.. probably will end up doing it that way, but then the whole rig would not be directly reacting to the target movement in my scene. That the way i have set it up. And it would be also nice to see this solved or mybe this isn't a issue with later versions.
     

    Share this post


    Link to post
    Share on other sites

    Re guns + targets - are you familiar with the XPresso preset soft target ? When the target moves, the thing pointing at it moves smoothly ie a bit more realistically. In your R18 version, I think it's in COFFEE, in R20 Python but works the same. Might be useful.

     

    soft_target.c4d

    Share this post


    Link to post
    Share on other sites

    You don't need to know COFFEE, it's a preset on the LHS of the XPresso window. The reason I mentioned scripting is because the preset used to be COFFEE but R20 has ditched COFFEE and Soft Target is in Python. I wasn't sure about the backwards compatability to R18. Soft Target can flip when the target goes around 360 deg, but there's ways round that.

     

    soft.png.c5a3526e9d81c89cb2a2211a8203103f.png

    • Like 1

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×