Jump to content

Hudson Lima

[HELP] Object reflecting HDRI scene

Recommended Posts

Hello everybody. There's something happening with my Cinema 4D and I can't solve it. Every time I add a reflectance material to any object, a HDRI image is being reflected on that. When I render the scene thats OK... that annoying image doesn't appear and the render looks how it was supposed to be. But it's so annoying to model the scene with that image being reflected in my objects... Could anybody help to turn that off? I've attached a print screen to show that even in a REALLY basic scene (just a sphere with a created high-reflectance material), the f*** HDRI environment keeps appearing.

 

I'm using Cinema 4D R20 in a Mac Pro (Late 2013).

 

Thanks in advance.

Screen Shot 2018-11-09 at 11.01.18.png

Share this post


Link to post
Share on other sites

Well, unfortunately not much you can do here. The thing you could do is to override HDRI map with simple black one in AM of Viewport Settings (Enhanced OpenGL tab) under Reflections --> Environment Override.

Hope that helps!

Share this post


Link to post
Share on other sites

If you make a Sky Object and a material with the HDRI in the luminance channel you could put the material on the Sky Object.  Now if you want this object only to reflect black, but others to get the reflection of the HDRI make a second sky object with a black luminance channel.  Stick a Compositing tag on the Sky Objects and set the one to Exclude the object and the other to include the object.

  • Like 1

Share this post


Link to post
Share on other sites

the refelctance is the default reflectance image...if you are using a material that has reflection , but there is nothing else in the scene or project to reflect, it uses the default HDRI. 
 

 The reason why your render doesnt show the default picture, is because there is no light....

 

Add a sky object with your own HDRI and it will use that one instead...

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×