Jump to content


heysprad

Same material acting different

Recommended Posts

Hello, I am new to C4D and am running into a problem with a material I created. (image attached)

 

I have the same high-reflective material on multiple objects, but on some objects, it is appearing matte and almost a slightly different color. I have tried different positions and angles thinking maybe it was lighting as well as different shapes thinking it was geometry differences. Is there another reason the same material would act differently on different objects? 

upload1.jpg

Screen Shot 2018-12-29 at 7.09.42 PM.png

Share this post


Link to post
Share on other sites

Hi

 

Normals or Smoothing from the Phong tag wont do this, so am wondering what that object does if you move it in the middle of the scene?  Do you have any other tags on the object such as on the sky object. A compositing tag with the object in the exclude list would do this.

 

I would also try putting that object into a new scene and see if it reacts the same.  It could also be the angle of reflection which is why I suggested putting the object in the middle of the scene.  Fresnel in the reflection settings would also do this as it changes the angle of reflection.  This works with a IOR setting, higher numbers brings the reflection more to the front.

 

If you can share the file or part of the file I can have a look. 

 

Dan

Share this post


Link to post
Share on other sites
  • Topic Author
  • Thank you both for your help! I tried a few more things with lighting and positioning, and it seemed to help somewhat, but I don't know that I know enough about Normals to know what I'm looking for if that is the problem. I do see that one of the objects has a UVW tag on it if this contributes to the problem. 

     

    I have uploaded the file below, and the items are in the TOWER folder. It wouldn't let me upload the entire file, so I removed some objects to make room. Thank you again for your advice!

    Infinite Floor Ted Red 11.c4d

    Share this post


    Link to post
    Share on other sites
    1 hour ago, heysprad said:

    Thank you both for your help! I tried a few more things with lighting and positioning, and it seemed to help somewhat, but I don't know that I know enough about Normals to know what I'm looking for if that is the problem. I do see that one of the objects has a UVW tag on it if this contributes to the problem. 

     

    I have uploaded the file below, and the items are in the TOWER folder. It wouldn't let me upload the entire file, so I removed some objects to make room. Thank you again for your advice!

    Infinite Floor Ted Red 11.c4d

    Your object has geometry where has overlapping faces sharing the same space, this is called Z fighting and produces all kinds of render issues.  Im sure if you remade that object all will be sorted.  I will continue to look at this scene for other issues and will report back.

     

    Edit:  After looking at it more although the zfighting can be a issue in which you will want to avoid having this kind of structure it was as I initially thought, the fresnel angle.  The object that looks dark in your render has reflections when its put at the same angle as the rest of the objects in the scene.  You should use a more accurate reflection type like GGX.  The objects needs more in the environment for there to be reflections from all angles of some kind.

     

     

     

    Dan

    different angle.png

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×