Jump to content

Adept

Animate on top of Motion Clip?

Recommended Posts

Hi!  Is there any way to add animation to certain bones on top of a character that is animated with motion clip?  I have blended a few walking animations for my character, but at one point in the middle of his walking I want him to twist his torso to turn. Is there any way to do this?  Like just edit the keyframes for the spine bone at that point in time?  Thanks!

 

Share this post


Link to post
Share on other sites

Hi,

You can go to Hierarchy Tab in the motion Clip and disable the mocap for certain Joints to keyframe them by hand. If you want to change in the middle of mocap Animation you might duplicate the Clip and blend from original mocap clip A to customized keyframed clip B

 

On cineversity is a helpful tut on Mixamo Clip blending in C4d


R18, Octane, Vray, Cycles, Zbrush, AE, Marvelous Designer, Substance Designer, Affinity

Share this post


Link to post
Share on other sites

Hi

 

when putting a clip onto a layer below the original top clip you can transition from the top clip to the one below it then transition back..  In my video at 1:21 this should show you this method along with what zeden has already covered.  

 

Share this post


Link to post
Share on other sites
  • Topic Author
  • On 1/11/2019 at 12:38 AM, zeden said:

    Hi,

    You can go to Hierarchy Tab in the motion Clip and disable the mocap for certain Joints to keyframe them by hand. If you want to change in the middle of mocap Animation you might duplicate the Clip and blend from original mocap clip A to customized keyframed clip B

     

    On cineversity is a helpful tut on Mixamo Clip blending in C4d

    How exactly do I disable the individual bones?  The only thing I have tried is pressing delete when the bone is selected, but then the entire model gets messed up....

    Share this post


    Link to post
    Share on other sites

    Click the motion clip in the animation timeline. Go to attributes window and open the hierarchy tab. Now you see all the objects inside the motion clip with checkboxes

    • Like 1

    R18, Octane, Vray, Cycles, Zbrush, AE, Marvelous Designer, Substance Designer, Affinity

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • 9 hours ago, zeden said:

    Click the motion clip in the animation timeline. Go to attributes window and open the hierarchy tab. Now you see all the objects inside the motion clip with checkboxes

    Aaahh there it is!  Thank you very much!

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • On 1/11/2019 at 12:38 AM, zeden said:

    Hi,

    You can go to Hierarchy Tab in the motion Clip and disable the mocap for certain Joints to keyframe them by hand. If you want to change in the middle of mocap Animation you might duplicate the Clip and blend from original mocap clip A to customized keyframed clip B

     

    On cineversity is a helpful tut on Mixamo Clip blending in C4d

     

    On 1/11/2019 at 1:15 AM, Rectro said:

    Hi

     

    when putting a clip onto a layer below the original top clip you can transition from the top clip to the one below it then transition back..  In my video at 1:21 this should show you this method along with what zeden has already covered.  

     

    Alright, well I've been messing with it for a bit now and still think I am doing something wrong.... First of all, the blending of two clips does not work as smoothly as it should (gif attached). Also, I am able to disable the bones in the heirarchy, but how do I animate them on top of the motion clip? Animating the bones in the heirarchy for my base clip doesn't work as once I click the keyframe button, the bones jump back to the position they were in before. What am I doing wrong? I just want to make his left arm move differently than was in the mixamo clips.

     

    https://gyazo.com/31e1b07eafdfc35e449998e22c4e1925 

    for mixing the clips, I used the "make transition" tool, but it doesn't seem to be working as well as I want...

     

    https://gyazo.com/33bf80f53d447cd13f3f8fb20162e876

    the bones are disabled, which shows in the viewport

     

    https://gyazo.com/037756ad0761eaeaa2d9cc6e733d2f0b

    but when I try to rotate/keyframe any of the bones here, it doesn't let me. Is there somewhere else I am supposed to do this?

    Share this post


    Link to post
    Share on other sites

    It seems like your 2nd layer is causing the glitches int he first example. Maybe try to bake your mixing into a single clip first. And in that second baked clip disable the arms and keyframe the joints in Object Manager. That might work.

     

    If not maybe load the file here up. It is hard to tell from gifs

     

    I can only reccomend to have a look at the cineversity tut. Do you have access to CV?

     

    https://www.cineversity.com/vidplaylist/mixamo_to_cinema_4d_character_workflow?utm_content=buffere6ae9&utm_medium=social&utm_source=twitter.com&utm_campaign=buffer


    R18, Octane, Vray, Cycles, Zbrush, AE, Marvelous Designer, Substance Designer, Affinity

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • On 1/22/2019 at 5:12 AM, zeden said:

    It seems like your 2nd layer is causing the glitches int he first example. Maybe try to bake your mixing into a single clip first. And in that second baked clip disable the arms and keyframe the joints in Object Manager. That might work.

     

    If not maybe load the file here up. It is hard to tell from gifs

     

    I can only reccomend to have a look at the cineversity tut. Do you have access to CV?

     

    https://www.cineversity.com/vidplaylist/mixamo_to_cinema_4d_character_workflow?utm_content=buffere6ae9&utm_medium=social&utm_source=twitter.com&utm_campaign=buffer

    No, I do not have access to CV, although it does look like their final segment of that series is what I'm looking for. I'll try baking into a single clip for now and see what happens.

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • On 1/22/2019 at 5:12 AM, zeden said:

    It seems like your 2nd layer is causing the glitches int he first example. Maybe try to bake your mixing into a single clip first. And in that second baked clip disable the arms and keyframe the joints in Object Manager. That might work.

     

    If not maybe load the file here up. It is hard to tell from gifs

     

    I can only reccomend to have a look at the cineversity tut. Do you have access to CV?

     

    https://www.cineversity.com/vidplaylist/mixamo_to_cinema_4d_character_workflow?utm_content=buffere6ae9&utm_medium=social&utm_source=twitter.com&utm_campaign=buffer

    Although, here is the file for anyone who can take a look and figure out what's going wrong  :)

    Mixamo_Motion_Clip_Mixing_with_Hand_Keyframe_Help.zip

    Share this post


    Link to post
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


    • Recently Browsing   0 members

      No registered users viewing this page.

    YOUTUBE CHANNEL:

    ABOUT US:

    C4D Cafe is the largest CINEMA 4D community. We provide facilities for discussion, showcasing and learning our favorite software :)
    ×
    ×
    • Create New...