Jump to content


Recommended Posts


  • Topic Author
  • 9 hours ago, Fastbee said:

    If you only want color coated glass it should be made like this.

    1256660360_cycles_glass_coatedchart.thumb.jpg.489a60311f2aac80d89590c02018b6c3.jpg

    cycles_glass_coated.thumb.jpg.39388ee409fcdd1ec572e26b0a9c9ccc.jpg

    looks great

    thanks for sharing this

    I haven't tried your setup

    mostly for coloured glass I used the glass shader node, but yours looks much, much better

     

    what I was trying is that glass effect you get with antireflective glasses (sort of)

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • @Fastbee

     

    can you tell me your setup with the caustics ?

    as far as Cycles4D documentation goes there has to be a Ray Depth node attached to it but never had any luck

     

    do you have a basic scene to share ?

    Share this post


    Link to post
    Share on other sites

    For antireflective glass your going to have to post a picture of exactly what you are looking for as ther are different types, but I'd say up the roughness and maybe lower the ior or color on the Glossy a bit.

     

    Caustics automatically appear in cycles so long as you have it turned on in the settings and have the refraction depth high enough.

     

    cycles_glass_coated fastbee.zip

    Share this post


    Link to post
    Share on other sites

    With the nodes set up with reflection and refraction separate it gives a lot of freedom.

    Below I changed the color of the internal glass to be different than the reflection.

    reflection refration different colors.jpg

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • I have a look how it is going

     

    one question as I have the Prime Version which has no caustics enabled unless I upgrade could that be the issue not getting caustics in Cycles?

    caustics are enabled in the Cycles render settings but perhaps it works only with certain lights or maybe I'm doing something badly wrong

    Share this post


    Link to post
    Share on other sites

    It should work as caustics in cycles is completely separate from caustics in c4d.  Download the file I uploaded and hit render.  It should have caustics.

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • with your help Cycles gets really fascinating

    the caustics show up nicely

    I'm experimenting with different light sources

    spectral caustics are a no go but I bet Cycles will include that feature at some point in the future

     

    thanks for helping me to understand

    Share this post


    Link to post
    Share on other sites

    Caustics like through a prism is possible.

    https://blender.stackexchange.com/questions/1602/light-spectrum-dispersion-effect-in-blender

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×