Jump to content


Sign in to follow this  
3D-Pangel

Trouble with R20 Nodes Cafe Tutorial

Recommended Posts

I have followed the Café tutorial  Hazard Symbol and get the same results until the final step.  For the life of me, I have no idea what I am doing wrong.  The attached image should help explain what I am encountering:

 

652237881_HazardHelp.thumb.JPG.b53c83ba1ccaf012706cc3981c7cbae6.JPG

 

Note that the problem is with the Pattern generator....while creating only 1 circle, the circle (while centered on the previews) appears 50% off in the U and V axis in the final material preview.  I have no idea why.  Plus when you render it...it is the only thing that appears.  Again, another mystery. I had to place it on a sphere just to see if anything turned up as playing with the UV on the plane (the test object in the tutorial) was not telling me anything.


I have gone through the tutorial twice....checked everything multiple times.  Is there some basic setting that is off?  I am pretty sure the answer will feel like a "dope slap" to the back of the head, but actually I am looking forward to a simple explanation as this one has me puzzled. 

 

 

The scene file is below:

Hazard Disaster.c4d

 

Thanks,

Dave

 

Share this post


Link to post
Share on other sites

You have the circle node set to solo in your scene, however there was a pattern node issue that is already corrected and will be a part of upcoming SP3. In meantime you can dive into pattern generator node and correct it. To do so, convert the circle asset to group then locate patterns for circle node and UV node, can't recall from top of my head where the issue was...

Share this post


Link to post
Share on other sites
  • Topic Author
  • 3 hours ago, HSrdelic said:

    You have the circle node set to solo in your scene, however there was a pattern node issue that is already corrected and will be a part of upcoming SP3. In meantime you can dive into pattern generator node and correct it. To do so, convert the circle asset to group then locate patterns for circle node and UV node, can't recall from top of my head where the issue was...

    Well...there it is....the dope slap to the back of the head as predicted.

     

    The real learning is in committing goof-ups like that.  Another one (which I figured out) was that the Invert Color node was not quite generating the black-white contrast that I wanted even  though all the generator nodes were looking to ONLY be black and white.  Well....turns out they were not.  They were 90% white rather than 100%.  That makes a difference when you invert them (turns out that 90% black is more noticeable as not being totally black  than 90% white is as not being totally white).

     

    Nothing like a good mistake to forever program your brain on what to avoid, never to forget, or what to check first.

     

    Is the pattern node bug causing this problem:  Look a the viewport image (now that the solo button is turned off)

     

    Viewport.thumb.JPG.b392decc4e59f884c49123b746bad5d5.JPG

     

     

    Now look at the image once rendered:

     

    Rendered.thumb.JPG.b40c589dae1676b4e740cba88bb317ee.JPG

     

    What happened to the outer circle?

     

    -Dave

    Share this post


    Link to post
    Share on other sites

    Yes, as I mentioned the asset in your version is still not updated :)

    If you are up to some manual work then do the following:

     

    - Right click on patterns generator and convert asset to group

    - Enter that group

    - Enter the first group node (will be called with fancy letters and numbers)

    - In that group there are "pattern" and "hollow groups

    - Enter each separately and delete projection node in both

     

     

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×