Jump to content

Sign in to follow this  
RichMed

Apply Plaster to Wound

Recommended Posts

Yes I agree - in my tests I found 80% transparency and 40% transparency blurriness worked well, with just 10% Bump strength.

 

When you make your lattice texture you need to make 2 maps - one with white dots on a black background, which will give you the main raised bumps, and then another one containing the circle outlines and lattices that you should Screen or Add it over back in Cinema within a layer shader in your bump channel...

That way you can vary the height of the bumps and the texture separately by just varying the amounts of each layer in the texture, if that makes sense...

 

CBR

Share this post


Link to post
  • Topic Author
  • Brilliant, finally i get all that, I know where you are coming from now. I'll have a go tomorrow so watch this space, fingers crossed I get it cracked. Thanks again.

    Share this post


    Link to post

    You're welcome - do show us your final result when you get there !

     

    CBR

    Share this post


    Link to post
  • Topic Author
  • Please see attached screenshot below, I am animating the plaster onto the wound with a bend deformer but the minute I apply the 'Collision Deformer' to push the impression of the foam through the dressing it does this...what am i doing or not doing, I am seriously stuck here.

     

    1982648089_Screenshot2019-03-28at12_15_10.thumb.png.fe61f545a9a72f40c46afaed458329ec.png

    Share this post


    Link to post

    In as much as I can see without the scene file I would say that your collision deformer probably has wrong mode settings and / or is in the wrong place in the hierarchy relative to the bend deformer...

     

    CBR

    Share this post


    Link to post
  • Topic Author
  • Think I have cracked it but now got another issue which is starting to 'P' me right off. Im at the stage of animating the  application of the dressing over the wound with basic key frames, moving the dressing into position and using a bend deformer to give it a more realistic application...however, the minute i add my key frame to close off the animation it jumps back to the previous key frame.

     

    All I want the dressing to do, is position itself so the black foam falls directly in the middle of the dressing I am trying to apply.

     

    I can't attach my file, its 8.5mb and I'm only allowed to upload 1.9mb, is there another way to share with you what i have done?

    And this is the first ever piece of animation I have ever done in C4D or anywhere for that matter, i've just had to google tutorials to learn.

    Share this post


    Link to post

    If files are too big to upload direct to the cafe, then you can either Zip them to make them less, or just use Dropbox etc, and then link that here instead.

     

    CBR

    Share this post


    Link to post
  • Topic Author
  • 22 minutes ago, Cerbera said:

    If files are too big to upload direct to the cafe, then you can either Zip them to make them less, or just use Dropbox etc, and then link that here instead.

     

    CBR

    I hope this works https://www.dropbox.com/l/scl/AACL-YSGxaH-5J44qoltbZp8Ysgx87dKmz8

    Share this post


    Link to post

    Man, there is a lot wrong with this file....

     

    Most of the problem is just because of badly made geometry. For example, take the pad thing, which has 4 massive ngons, and drastically uneven topology that is likely to confuse the Collision Deformer.

     

    1985051171_ProblemGeo2.jpg.67a2175d3cba7e9b1a351c93ab239ec7.jpg

     

    Then we have an issue with the thing you are trying to deform as well - because this hasn't been modelled properly it's full of gaps along the edges, non-coincident points and triangles, and again, the Collision Deformer doesn't know what to do with it and is getting confused.

     

    1838305558_problemGeo1.jpg.6e1833eed50c723b36da36a99ae10653.jpg

     

    Lastly (so far) you had a whole load of positional keyframes on the Collision Deformer of all things ! That shouldn't move.

     

    There is also some hierarchy confusion happening with what deformers are applied where, and to how many things, so all these things need looking at too before we have a stable setup.

     

    I suspect there are additional problems I haven't found yet, but I have to go out now, so hopefully you have enough to be getting on with fixing the ones I have...

     

    Also, we should note that the Collision Deformer is designed primarily for single surfaces to deform, and has never done well with surfaces that have a very thin level of thickness to them like this does. It may be that even when you fix this geo the lower surface will always jump underneath the collider when the top surface is close enough to collide with the the top of it. In that case you'd either have to lose the thickness from that part, or keep that and use a pose morph instead to do the bulging as it lands, morphing in Points Mode. 

     

    CBR

     

     

    Share this post


    Link to post
  • Topic Author
  • 18 minutes ago, Cerbera said:

    Man, there is a lot wrong with this file....

     

    Most of the problem is just because of badly made geometry. For example, take the pad thing, which has 4 massive ngons, and drastically uneven topology that is likely to confuse the Collision Deformer.

     

    1985051171_ProblemGeo2.jpg.67a2175d3cba7e9b1a351c93ab239ec7.jpg

     

    Then we have an issue with the thing you are trying to deform as well - because this hasn't been modelled properly it's full of gaps along the edges, non-coincident points and triangles, and again, the Collision Deformer doesn't know what to do with it and is getting confused.

     

    1838305558_problemGeo1.jpg.6e1833eed50c723b36da36a99ae10653.jpg

     

    Lastly (so far) you had a whole load of positional keyframes on the Collision Deformer of all things ! That shouldn't move.

     

    I suspect there are additional problems I haven't found yet, but I have to go out now, so hopefully you have enough to be getting on with fixing the ones I have...

     

    CBR

     

     

    I did warn you I'm a noob and it appears I have over committed with this project, I really don't know where to start, its taken almost 4 weeks of blood, sweet  and tears to get to this stage... to put it mildly.

    Share this post


    Link to post

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×
    ×
    • Create New...