Jump to content

Sign in to follow this  
TheOtherOne

Sketch & Toon lines problem

Recommended Posts

Hi

 

 I'm having a problem with lines in the S&T effect. What I'm trying to do is render only the edges of the Sphere( Octahedron) and cloned rectangles. In case of the sphere it looks like it picks up only some of the edges - I already played with the Phon Tag as well as Creases Min bar in the Render settings but it didn't do the trick.

 

If it comes to the squares, only the vertical lines are rendered out.

 

*EDIT*

 Increasing the the Image Resolution (from 1500 to 5000 pxls- width) brought the horizontal lines. I assume there are some relations between lines Thickness, image resolution and distance between the camera and geometry ( and pixels density?). But I'm not sure if I'm understanding this correctly.
 Also let say I need to render it out to the 1500 pxls width and still need all of the four edges of the squares- I fell there is some little trick but I can't find it, or I already made mess in the settings :)

 

 Could someone explain to me what happened there as well as help me with the Octahedron?

 Thanks !

 

P.s. The first pic is 5000pxls rendering, second 1500 pxls and third just a screencap.

1 Rendering 5000pxls.jpg

2 Rendering 1500pxls.jpg

3 Screenshot.jpg

Sphere & Squares.c4d

Share this post


Link to post
Share on other sites

hi,

 

un-click Filter strokes on the Strokes page of material.  your lines will come back at 5000px

 

you can also use the resolution setting for line width in the render setting under sketch & toon Render tab

 

Share this post


Link to post
Share on other sites

2 things going potentially wrong there... but both easily fixable...

 

261382791_sntfixed.thumb.jpg.c69ad3dcb3e7d7492143fff88088bf65.jpg

 

1. Resolution independent needs to be ticked in the SnT Render Tab if your render dimensions are different from the viewport size...

 

ResInd.thumb.jpg.4794f7fb67a606e41def5df4e113295e.jpg

 

2. You had Stroke filtering on by distance, which is why your top and bottom lines of the squares were only visible when you zoomed in (editor) or upped render resolution. Turn that off, and you see all the lines all the time.

 

307950075_filterstrokes.thumb.jpg.f67e22f3f420eb868e5e2526b603d0f8.jpg

 

3. Once those settings are right, you should only need Edges ticked in the main SnT Lines department.

 

CBR 

Share this post


Link to post
Share on other sites
  • Topic Author
  • Wow thanks for a such informative answers! Now everything works perfectly.

     Thanks a bunch !

    Share this post


    Link to post
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    Latest Topics

    Latest Comments

    ×
    ×
    • Create New...