Jump to content
Amy Sterling

Why is the sand sparkling?

Recommended Posts

I've been working on the intro to Cinema 4D video series from Cineversity. It's going well so far and I'm getting easily obsessed with C4D... but there is something weird with my render. The sand is sparkling. Any idea what is causing this static look? Here is the project file. https://drive.google.com/open?id=17gy_OatCCosxGRuu57k45vOe6y-ecTJi

 

 

 

Also the fish in the scene look very different than the ones that render out. 

Scene:

image.thumb.png.215ece08d8a23374ebce28f29102d560.png

 

render: 

image.png.db9f22784e67c800f36906cf1d183e51.png

 

The tails change shape and they seem to lose the bulge in the body. *** mate! 

 

Thanks for the help!

Amy

 

 

 

 

 

Share this post


Link to post
Share on other sites

Make sure there is no roughness/noise in your glass material reflectance or transparency.

  • Like 1

Share this post


Link to post
Share on other sites

The problem with the fish tails is that you have hidden the 'fail fish' from the viewport, but not the render. 

  • Like 1

Share this post


Link to post
Share on other sites

Are you using ProRender?  It looks like a sampling issue.  We call these "fireflies" and they frequently appear in GPU rendering.  Usually the only way to get rid of them is increasing samples.

  • Like 1

Share this post


Link to post
Share on other sites

@Vizn aha killing the fail fish fixed the tails, thank you! There looks to be no roughness or noise in the glass. I just redid the material and re-rendered and same thing. 

 

754872463_subrenderfishfix.thumb.png.30169ed3faf0665964ee6f6c89adbc6b.png

 

@natevplas I am using Standard render.  

Share this post


Link to post
Share on other sites

when I render in view, it has the dots even outside the glass bowl hmm

 

image.thumb.png.4a64154cc5355da086e6ba91bccb8e13.png

Share this post


Link to post
Share on other sites

No roughness? Odd, because in the file the 'glass bowl' material definitely has roughness in the Reflectance Transparency tab. Is the provided file identical to the one you are rendering from? I don't get any light specular/reflections in the glass, and the render output settings don't seem to be set for animation. Otherwise, look into the rendering samples as Nate suggested.

 

This is what I get when opening and pressing render.

1781455210_submarineobjectcreationtest34.thumb.jpg.3cfea81fd53e662f464913fb5019cb04.jpg

  • Like 2

Share this post


Link to post
Share on other sites

@Vizn yeah, i just downloaded the file and took a look... No fireflies here.  It's set to Standard Renderer, so that makes sense.  But not sure why @Amy Sterling is getting them unless she changed something before/after uploading. 

Share this post


Link to post
Share on other sites

Ok!  Now I'm getting the fireflies!  That's pretty strange.  I've never seen that with Standard renderer.  BUT, the fix is super easy.  Just turn on Anti-Aliasing in Render Settings.  And make sure if you're using the interactive view (and you don't want to see the sparkles) you move that little tiny triangle on the right side of the window all the way to the top.  That's your quality control.

image.thumb.png.87e9d8b781933a3fa7594bef296e71d5.png

Share this post


Link to post
Share on other sites

Is this where you adjust it? Is it already on? 

 

image.thumb.png.1603ac6d553f9e959974a2d9c1394e7e.png

 

That render you made looks so nice! The in-view render takes *so long* even at low resolution so I keep turning it off.

Share this post


Link to post
Share on other sites

Oops!  Forgot to mention how to do that.  Change it from "Geometry" to "Best."  I left the other settings as is, but you can increase the minimum from 1x1 to 2x2 for even better results.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

YOUTUBE CHANNEL:

ABOUT US:

C4D Cafe is the largest CINEMA 4D community. We provide facilities for discussion, showcasing and learning our favorite software :) Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, get your own private messenger, post status updates, manage your profile and much more. If you need to find solution to your problem or otherwise ask for help, Cafe is the right place.
×
×
  • Create New...