Jump to content
HiFly

Symmetry | Extrude | Axis

Recommended Posts

Hi C4D Cafe

I'm new to the Cafe, and C4D and currently working through modelling tutorials. I'm using demo version R20 and have found an anomaly when trying to 'extrude selected' polygons along a symmetry edge. 

 

I have both the 'clamp polygons on axis' and 'delete polygons on axis' boxes ticked, but I keep generating a dividing polygon along the symmetry edge. I can delete the unwanted polygon when using right angles, but it's causing me an issue when the symmetry line is on a curved edge.

 

Attached is a screenshot where I have selected the edge of the unwanted polygon.

 

Any help would be much appreciated, I've given today to trying to find a solution but have come up short.

 

Thank you

Screenshot-2019-05-25-at-17.38.04.jpg

  • Like 1

Share this post


Link to post
Share on other sites

This shouldn't happen often, but sometimes can, depending on circumstances and weld thresholds, and the nature of the operation you are trying to perform. Usually it is caused by the centreline of edges not being exactly centered and zero scaled or you might need to just raise the threshold a little. Also the Symmetry has to be on and active while you make the modelling move.

 

But it's not a thing to worry about, and never a serious problem, because you can always just turn symmetry off, and delete those polys yourself before turning it back on again and continuing...

 

CBR

 

PS - I very much like your avatar, which suggests you know what's important about modelling :)

  • Like 1

Share this post


Link to post
Share on other sites

Hi CBR

 

Thanks for taking the time to respond and for commenting on my avatar – the first lesson I've learned is that I've entered the land of four sides. 

 

Thanks for your advice. Attached are three pictures, as I might be missing something because I can't work this situation out.

 

The first picture shows that I've checked that all the centre points are at word zero on the z-axis.

The second picture shows that once I perform the 'extrude selected' I get a bunch of troublesome points which are all off the z-axis, so if I delete the unwanted polygon created along the centre line, I'm left with the two surfaces protruding through each other.


In the third picture, I've manually moved the protruding points back to world zero, but I have messy geometry and also the surface doesn't look smooth as it should.

 

I've also tried a tolerance of 0.1 cm, 1 cm and 10 cm and they all act the same.


I like very much to get to the bottom of something if I can, but I am struggling with this and will continue through the rest of the tutorial today.

 

Appreciate your time and any pointers you might have.

 

Thank you

Grabs.zip

Share this post


Link to post
Share on other sites

No pics attached so far... but when you do add them, could you also please upload your project (.c4d) file. Thx.

 

CBR

 

  • Like 1

Share this post


Link to post
Share on other sites

I had problems uploading the images but have now attached them to the previous post. Attached to this post is the .c4d file.

 

Much appreciated

Handle.c4d

Share this post


Link to post
Share on other sites

OK, well, you are doing everything right there, and I can confirm that errors every time, so looks like you have discovered a new bug in R20.59 !

Bizarrely, it works fine until you release the mouse button, at which point the new broken surfaces appear. That is not a trivial problem, so I will report that via the normal channels, and to @Igor directly.

 

In the meantime there is a work-around. Do a zero-extrude, then use Normal Move to get the polys where you need them instead...

 

Normal_Move.thumb.gif.890e061819c7d4d86478c6867691bdc4.gif

 

PS - you have 2 stray points at the base of your model. Points mode, Select All and Optimize to fix those.

 

CBR

  • Like 2

Share this post


Link to post
Share on other sites

Ahh, I really appreciate you looking into this and for the work around. Amazing. Amazing. You've made my day, I can get on learning now but the upshot is that I feel as though I at least know the symmetry tool pretty well now after focussing heavily on it trying to fix this issue. Thanks again, especially for the work around. And your time. ;-)

  • Like 1
  • Namaste 1

Share this post


Link to post
Share on other sites

This is too damn funny. HiFly must be my cosmic twin.

 

I was going through the exact same same tutorial yesterday and having the EXACT SAME PROBLEM. I kept wondering what modeling step I was doing wrong and then I finally rewound the video to see that the instructor had different settings with the symmetry object. Once that was changed it worked perfectly.

 

Toby Pittman and Making it Look Great training is...awesome! 

 

Cerbera + Toby Pittman =learning heaven. :geek:

  • Like 1
  • Haha 1

Share this post


Link to post
Share on other sites

Alright Cosmic Twin ;-) 

 

I agree, great tutorial, but I would have been soooooooooo stuck without Cerbera's help.

 

Can you tell me what you spotted as I'm pretty sure all my settings were the same as the instructors, and there was no way this feature was going to work for me, in my version of C4D, without Cerbera's workaround?

 

Thanks

 

Share this post


Link to post
Share on other sites
52 minutes ago, HiFly said:

Can you tell me what you spotted as I'm pretty sure all my settings were the same as the instructors, and there was no way this feature was going to work for me, in my version of C4D, without Cerbera's workaround?

I will be interested to hear that too, because in my tests there was simply no setting in Symmetry that could have avoided this, yet it all works like a charm in R19...

 

CBR

  • Like 1

Share this post


Link to post
Share on other sites
9 hours ago, HiFly said:

Alright Cosmic Twin ;-) 

 

I agree, great tutorial, but I would have been soooooooooo stuck without Cerbera's help.

 

Can you tell me what you spotted as I'm pretty sure all my settings were the same as the instructors, and there was no way this feature was going to work for me, in my version of C4D, without Cerbera's workaround?

 

Thanks

 

I fiddled with multiple things so I can't reliably say. When I turned all of these to ON: "Clamp Points on Axis" and "Delete Polygons on Axis" and "Weld Points" it resolved. I think I also played with Tolerance. But perhaps it was this in combination with some other previous tweak...

 

I fiddled with it for twenty minutes or so before I got the desired result. I'm on R20 20.059

 

I definitely resolved without using 'Normal Move' or 'Normal Scale' as Cerbera did.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

YOUTUBE CHANNEL:

ABOUT US:

C4D Cafe is the largest CINEMA 4D community. We provide facilities for discussion, showcasing and learning our favorite software :) Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, get your own private messenger, post status updates, manage your profile and much more. If you need to find solution to your problem or otherwise ask for help, Cafe is the right place.
×
×
  • Create New...