Jump to content
Sign in to follow this  
3dkobi

How to Blend those objects

Recommended Posts

Hi guys,

I'm having another mograph problem...

Super simple scene - A cloner clones 2 objects on a distorted sphere. I also have a shader effector with the same noise as in the displaced  sphere. 

The 2 objects under the cloner are 2 cubes - one regular and the other with full fillet, so it is actually a sphere.

When I set the cloner mode to "iterate" I can see the 2 different objects (a cube and a sphere). 

When I set the cloner mode to "blend" I can see only the cubes.

 

How can I make the objects to blend in the animation ?

 

Scene file is attached

 

Peace,

Kobi

SharedScreenshot6.jpg

SharedScreenshot125.jpg

Abstract 5.zip

Share this post


Link to post
Share on other sites

HI Kobi,  just check Render instances that should do it.

Share this post


Link to post
Share on other sites
  • Topic Author
  •  

    5 minutes ago, digitvisions said:

    HI Kobi,  just check Render instances that should do it.

    that didn't work

    Share this post


    Link to post
    Share on other sites

    OK , i am on R15 it works here: 

    abstract.jpg

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • that's not the blending I mean - I want a smooth transition between the 2 objects

    Share this post


    Link to post
    Share on other sites

    you have to have fillet enabled on both input objects :)


    Free C4D trainings from MAXON professional on our youtube channel

     

    https://www.youtube.com/c4dcafe

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Oops...you're right :)

    I'm using C4d for about 10 years now, but it was always for arch-viz. Since I upgraded from prime to broadcast, in the last weeks  I've started to dig into mograph...I feel like a total newbie again with silly questions that has so simple answers :)

     

    EDIT:

    I think I didn't explain myself good enough...I'm looking for a way that the shape of the cubes will also change in the animation as they move around . Now all I get is that the objects are moving and scaling

     

    Share this post


    Link to post
    Share on other sites

    Check the parameter tab of the effector. Set "Modify Clone" to 100% to control the blending with the effector. I've attached a simplified example. 

    Clone_Blending_with_Effectors.c4d

     

    Since you are also using dynamics: Keep in mind that the cloned position is used to sample the falloffs/fields and not the position resulting from the dynamics simulation. When working with a noise that is probably not that important but it is hard to tell what exactly you are trying to achieve here. If that becomes an issue you can split the setup. One cloner (cached!)  just for the initial distribution and the dynamics and a second one (in object mode and cloning on the axis of the first cloner) to do the actual blending with effectors. 

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Thanks Havealot - That works perfect

    Share this post


    Link to post
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×
    ×
    • Create New...