Jump to content

Sign in to follow this  
Bolos

OpenEXR compositing in AE

Recommended Posts

Hello,

 

I followed Tim Clapham's tutorials about Linear Workflow and Straight vs Premultiplied Alpha to get the cleanest compositing possible between C4D and AE (CC2018) and got pretty close to it but I still have a little grey line at the edge of the alpha :

 

193794558_ScreenShot2019-07-15at13_13_13.thumb.png.9f6d52e373651e2463e32443bc79e2a6.png

 

I tried with a premultiplied alpha and a straight alpha ; I end up with this grey contour on both.

 

I already fiddled a lot to get this far and I don't know what I could do besides maybe using Matte choking in AE but I'd like to avoid this solution.

 

Here's some screenshots of my C4D and AE settings, you might see something wrong and hopefully help me get this right.

 

Thanks in advance!

 

 

Screen Shot 2019-07-15 at 13.26.18.png

Screen Shot 2019-07-15 at 13.18.24.png

Screen Shot 2019-07-15 at 13.17.51.png

Screen Shot 2019-07-15 at 13.12.58.png

Screen Shot 2019-07-15 at 13.12.34.png

Screen Shot 2019-07-15 at 13.29.07.png

Share this post


Link to post
Share on other sites

Hmm, what are your anti-aliasing settings?  And have you tried exporting the alpha as a separate file?  One other random idea I had would be to bump it up to 32 bpc.

Can you upload your file?  You could even just replace your lizard with a sphere as long as it's give you the same problems.

Share this post


Link to post
Share on other sites
  • Topic Author
  • Thanks (again) @natevplas, antialiasing is default Physical render I guess ; Cubic (still image).

     

    I did not tried yet rendering in 32 bpc or exporting alpha alone, but if you want to dive in, I uploaded a zip of the C4D and AE projects here (If you have extra time to look at why my lights are still reflected in the eyes despite adding the latter in the lights project tab, that would be super cool).

     

    edit : lights problem solved

    Share this post


    Link to post
    Share on other sites

    Hi,

     

    Try checking both Alpha and Straight Alpha in render settings, and put Anti-Aliasing to "Best", with Min=1, Max=4, and Filter="Gauss (Animation).

     

     

    Dane

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Thanks for the tip @danijelk! I tried it with the same settings but all it seems to do is softening the grey line. 

    Share this post


    Link to post
    Share on other sites

    Ok, I finally got a chance to look at your files!

    Looks like it's not so much an alpha issue, but rather how you are compositing these layers together.  You have your color layer WITH an alpha channel and your Specular and Luminance layers WITHOUT alpha channels (I don't think they can have alphas, actually).  Try outputting your color layer without alpha and see if it solves it.  Looks like you already have Object Buffers set up which you can use for a Track Matte in AE if you need to separate the lizard from the background for some reason.

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Ah okay, thanks for the information. The problem when I select layers of the OpenEXR with ExtractoR is that the layer selected gets really dark. When ExtractoR is disabled, it looks like the C4D render. I did 32bit renders (and changed the AE project to 32 bpc) but I also have the same problem.

     

    Also holy heck, 90mb/frame in 32bpc, I'm not sure that's a good idea for my RAM and hard drive :/

     

    Not sure if this will help but here's what I had in mind :

     

    I'm really fond of the shiny reflective look you can get with the Luminance art shader, but you can't really have uv textures with it.

    I just found out that using a greyscale art shader and compositing it with full color/luminant textures allow me to get the look I want.

     

    I don't really need to knock out the background on this project but I'd like to make more complex animations later where I'd need that. So I'm trying to see how that can be done with a nice and clean multi-pass render.

    Share this post


    Link to post
    Share on other sites

    Did you switch on Linearize Working Space?  Mess with these settings.  You can also try right clicking your footage in the Project panel and clicking "Interpret Footage."  Under Color Management try checking or unchecking "Preserve RGB"

    image.thumb.png.da5cd725d33d1cc99e494742d482f0c4.png

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Thanks and yep, I had Linearize Working Space all the time. I tried a lot of settings (Preserve RGB on/off, Compensate for Scene(…) on/off, changing working space from Rec. 709 to SRGB and others), but it's always darker with ExtractoR on.

     

    I also noticed that with Linearize Working Space off, the comp gets even darker. Here's another screenshot :

     

    1622932260_ScreenShot2019-07-17at16_28_53.thumb.png.7c94872a4391377fa5734e14398c71de.png

    Share this post


    Link to post
    Share on other sites

    I see in your Timeline that you have one layer Multiplied over another.  Does this darkening happen to just a plain render (not a single pass or composite)?  It might be that you are missing some pass(es) from C4D to complete the image.

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Not sure to get what you mean but when I import the .exr without any effect it looks like the C4D render. But then with ExtractoR it gets darker. Also when I had a look at single passes in the C4D picture viewer, I had the same "lightness" (gamma I guess) between the global image and the luminance channel (or others).

     

    Here's other screenshots where you can see the "luminance premult" file with ExtractoR "on" is darker than the thumbnail in the Project tab. The second one shows the same file without ExtractoR on and looks like what I'd expect.

     

    If that makes sense :)

     

    277925293_ScreenShot2019-07-17at17_31_21.thumb.png.c0947a8d0c17afabe962e74a9f78577b.png

     

    487299188_ScreenShot2019-07-17at17_32_33.thumb.png.82be3c36afe77c33342dca07d98862cb.png

    Share this post


    Link to post
    Share on other sites

    Hmm, I'm out of ideas...  Maybe contact Adobe support or MAXON?

    Share this post


    Link to post
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    Latest Topics

    Latest Comments

    ×
    ×
    • Create New...