Jump to content

Sign in to follow this  
pfistar

ThinkingParticles and MoGraph Cloner

Recommended Posts

Hi all,

 

I have a MoGraph Cloner setup set to Object mode, where a TP particle group is being used as the framework for cloning. The object being cloned is a simple mesh sphere, though the Cloner has MoGraph Multi-Shader applied to it so that the particles are 5 different colors.

 

After a couple test renders, I'm noticing that once I have cached my clones to disk using the MoGraph Cache tag, C4D only renders a fraction of the clones. Here's a side-by-side-comparison: https://www.dropbox.com/s/k4xq8teg9bzfdms/cached_v_uncached.mp4?dl=0

Also, here's my scene file: https://www.dropbox.com/s/4nhz9hnjn5if40o/VID1_Shot05_Disintegration_v13_mograph-cache-test_more2.c4d?dl=0

 

I did a test in AfterEffects to make sure things line up, and sure enough they do - the only problem is that the cached version is missing what looks to be about half of its clones. Is this normal behavior for the tag, or have I missed something in the setup?

 

Thanks ahead of time for any insights...

 

NpF

 

 

cached (0-00-08-16).jpg

Share this post


Link to post
Share on other sites

Scene is very heavy and thus difficult to troubleshoot since I am on laptop atm. Currently your cloner is set to render instances. Try using instance mode and cache then to see if that resolves the issue?


Free C4D trainings from MAXON professional on our youtube channel

 

https://www.youtube.com/c4dcafe

Share this post


Link to post
Share on other sites
  • Topic Author
  • Hi Hrovje,

     

    Many thanks for this reply also! 

    Apologies for heaviness of scene. When I have a spare minute I'll parse out whatever's less than necessary and send a new link. 

     

    I tried turning "render instances" off, though I'm still getting the same result, where only a fraction of the clones show up at render-time. I also pushed up the "Max Particles" count in the Thinking Particles Settings panel, just to see if this would do anything, though I suspect this is not where the problem lies.

     

    Otherwise, I'm not sure what you mean when you say "try using instance mode..."  

    Does this mean first creating an instanced version of the cloned sphere object and using that under the cloner object?

    Or could it mean some function in one of the TP nodes in Xpresso? Sorry I'm a bit confused.

     

    I should mention I seem to be having the same problem in another scene as well where I'm using Cloner with any ThinkingParticles that have more than one Particle Group within a hierarchy. Does this sound familiar at all to you?
    I may just end up using brute force solution of using one Cloner object per Particle Group.

     

    Thanks again for your reply and your insights!

    Nik

     

     

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Hi Hrovje,

     

    I finally had a little time to slow down and explore this problem. It turned out that the problem was not with the Cloner's  instance function. It appears it was rather because I had cached my sim while my viewport LOD was not set to 'High', and along with that, there's a setting that translates that Low/Med/High setting to your CPU Render settings. I'm pretty sure this was the problem, though it took a little while to parse this as there were a number of other factors which I thought might have been suspect with this combination of features. (ThinkingParticles | TP Groups | MoGraph Cloner | MoGraph Cache | MoGraph Shader | RandomEffector | viewport LOD feature | and also the Takes function )

     

    For what it’s worth, here’s a pared-down version of the scene, though with the Cloner Cache inactive so as to not have to link you to another huge file.  

    https://www.dropbox.com/s/2i66pw36zotz5hj/TP-mograph-cache-v03.c4d?dl=0

     

    For my own clarity, I made a quick index of dependencies for once a TP sim has been cached. Happy to share it in this thread if you’re interested at all.

    Thank you again for your help and insights!

     

    NpF

    Share this post


    Link to post
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×
    ×
    • Create New...