Jump to content
Sign in to follow this  
janheylen

R21 IRR slow/doesn't update

Recommended Posts

I installed R21 and the interface is much sharper and looks good on a 4K screen. So far the good news.

Unfortunately the IRR became slower and doesn't automatically update when you change a parameter. (which is the whole point of the IRR)

A lot of the time the screen just stays black. When I'm building a shader I rely on the IRR to quickly update when I change something to see the result.

Now this workflow is broken. I have to hit ctrl+R all the time to make a screen render.

Does anyone else have this problem?

Share this post


Link to post
Share on other sites

I have had this problem intermittently with all versions since Physical Render was first introduced, and must admit that it has been the case for me occasionally with R21 too...

 

I have yet to establish what causes it to suddenly do this, which makes it very difficult for even a Beta tester to report or a developer to bugfix. I am usually able to solve the issue by disabling IRR, changing renderer to Standard and back to Physical again, then restarting the IRR, but I wouldn't call that anything like bulletproof, so would be interested to know if it helped you at all.

Have you done a support ticket about this, and did you ever get this problem in previous versions ?

 

CBR

Share this post


Link to post
Share on other sites
  • Topic Author
  • I never had this problem in R20. I never used the IRR much before.

    But the last few weeks I was learning the node system and for this the IRR worked fine, never had a problem with it.

    I tried your solution, thx for that, but it didnt work.

    After several times,  changing renderengines and turning the IRR on and off, C4D crashed.

    I took the opportunity to write a bugreport.

    Now the IRR updates again, but very slow. Just changing the color of a basic material applied to a sphere lit by one directional light takes almost two seconds to render.

    In R20 this was almost instantaneously.

    Share this post


    Link to post
    Share on other sites

    works just fine here... changing any parameter in materials forces the IRR to refresh instantly. so do any changes with lights, objects and so on.

    Share this post


    Link to post
    Share on other sites
    6 hours ago, janheylen said:

    After several times,  changing renderengines and turning the IRR on and off, C4D crashed.

    I took the opportunity to write a bugreport.

     

    Oh well that's something, at least there will be the right people looking at the issue.
    When this next happens to you, could you do me a favour ? Disable IRR in the current scene, start a new scene, maybe insert just a couple of random objects and open the IRR there.

     

    Is it still broken in that new scene ? If you could let me know in this thread that would be helpful. Cheers.

     

    CBR

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • In a new scene the IRR fuctions again.

    I also tried copying the objects from the scene with the broken IRR to a new scene and in this new scene the IRR works again.

    So that's a workaround but the problem returns quite fast.

    For example when i'm changing the color of a material the IRR wil sometimes update and sometimes just turn black and not render anything.

    It seems to be mainly a problem when you change a parameter with a slider.

    When I enter a numeric value and press enter or change a node connection the IRR will be more responsive (but still not always)

     

    Share this post


    Link to post
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×
    ×
    • Create New...