Jump to content
Sign in to follow this  
paulselhi

Poor Renders

Recommended Posts

The staircase02  content browser scene file !! What a peeved poor render !! Why include that if the result is a useless grainy image ? Cannot upload the tif only a jpg but the result is the same.

Staircase - Room 02.jpg

Share this post


Link to post
Share on other sites

It's the default setting for the image because they want to show have fast their render engine is.  Thing is their render engine is super slow when doing a scene like this when compared to redshift, cycles, or octane.  If you are rendering something simple and don't need GI the render engine in C4D is great.  Anything with GI it dies.

Share this post


Link to post
Share on other sites
On 9/8/2019 at 9:35 AM, Fastbee said:

It's the default setting for the image because they want to show have fast their render engine is.  Thing is their render engine is super slow when doing a scene like this when compared to redshift, cycles, or octane.  If you are rendering something simple and don't need GI the render engine in C4D is great.  Anything with GI it dies.

You don't even need GI. It dies a horrible, painfully slow death as soon as you get reflectance into the picture. The C4D render engine is great for anything that can be solved with very simple shaders or if you can fake a lot of stuff, but as soon as you need (rough) reflectance and / or GI you're better of with anything else.

However, if you DO have the time to actually let it render out you have a (visually) pretty capable render engine, in my opinion. You just can't expect Octane or Redshift speeds from it. I assume they thought Prorender would actually replace it at some point, at least for visually complex scenes. But at this point we all know how that turned out, at least for now

Share this post


Link to post
Share on other sites
12 hours ago, DasFrodo said:

I assume they thought Prorender would actually replace it at some point, at least for visually complex scenes. But at this point we all know how that turned out, at least for now

ProRender.  You mean SlowRender

Share this post


Link to post
Share on other sites
On 9/10/2019 at 12:39 AM, Fastbee said:

ProRender.  You mean SlowRender

Cmon, it's not THAT slow. I mean yeah, it's definitely slower than Redshift and Octane but it's not THAT bad. Still miles faster than Standard / Physical.

Share this post


Link to post
Share on other sites
4 hours ago, DasFrodo said:

Cmon, it's not THAT slow. I mean yeah, it's definitely slower than Redshift and Octane but it's not THAT bad. Still miles faster than Standard / Physical.

I just tested it again without using Cycles denoise because SlowRender has denoise now.  Rendered till it looked like the same level of noise.

 

Prorender: 18 min. 57 sec.  Note Fresnel does not seem to be working in Prorender with R19.

649662228_recessedlightsprorender.thumb.jpg.031e7aaf0115fe6422163924d2066aa1.jpg

 

Cycles 1 min. 4 sec.

2136658603_recessedlightscycles.thumb.jpg.80fe6d63a404318825eae6f5ed187c82.jpg

 

So 17.77x slower than Cycles.  When Cycles gets the RTX out it will be 2x faster so ProRender would be 35.53x slower.

Yes it is THAT slow.

Share this post


Link to post
Share on other sites

1.47m in pro render.. seems decent enough. Probably another reason why it's so slow for you maybe?

 

Like what setup do you have? Settings for the scene, and so on.

 

But that original scene could have been set up better.. I don't know how old that one is.. but it seems to me it was setup for a much older version of C4D. Not that my darker one suggest a better way to set things up either 🙂 It was just a prorender test.

 

Staircase - Room 02_mt_00.jpg

Share this post


Link to post
Share on other sites
2 hours ago, Mithril said:

1.47m in pro render.. seems decent enough. Probably another reason why it's so slow for you maybe?

 

Like what setup do you have? Settings for the scene, and so on.

 

But that original scene could have been set up better.. I don't know how old that one is.. but it seems to me it was setup for a much older version of C4D. Not that my darker one suggest a better way to set things up either 🙂 It was just a prorender test.

 

Staircase - Room 02_mt_00.jpg

What are your hardware specs.  If you have quad AMD cards of course your render are cleaner with the same time.  It also looks like you are using denoise.  Turn denoise off.  What version of C4D are you running?

 

I got a single Titan X Maxwell.  This is what I get with that scene after 2 min.

1216251393_Staircase-Room022m.thumb.jpg.45494e16153b95333cd373d2b3afb5ee.jpg

Share this post


Link to post
Share on other sites

Downloaded R21 trial and content library and this is what I got after 2 min.  It's better, but it still seems super slow.

1704764877_Staircase-Room02r21.thumb.jpg.2a850bc3a898c4aa98c3c525d2960157.jpg

Share this post


Link to post
Share on other sites

I turned on the denoise in R21 and wow.  It kicks butt.  If I use that denoise with cycles it gets same quality 17.77x faster than Prorender still so ya it's SlowRender.

 

Image with denoise. 2 min.  I think I got the sun angle right which I had to add in separate so it would work in Prorender.

1816577827_Staircase-Room02denoised.thumb.jpg.291184f15d5637e755136cde833f0691.jpg

 

Raw image without denoise 2 min.

1389907428_Staircase-Room02nodenoised.thumb.jpg.96d37b2a0a879a230cd707c8729c2bb9.jpg

 

My sun angle is H49.374, P-32.788, B3.215. 30% intensity color pure white.

Share this post


Link to post
Share on other sites

Here is the longer render with SlowRender with no denoise 16 min.

Notice the fine detail in the carpet.  This is why denoise should be used lightly when the image is almost grain free.858923882_Staircase-Room02prolongrender.thumb.jpg.a27d4b6334410eea99de20fb427d55d4.jpg

 

Share this post


Link to post
Share on other sites
16 hours ago, Fastbee said:

What are your hardware specs.  If you have quad AMD cards of course your render are cleaner with the same time.  It also looks like you are using denoise.  Turn denoise off.  What version of C4D are you running?

 

I got a single Titan X Maxwell.  This is what I get with that scene after 2 min.

1216251393_Staircase-Room022m.thumb.jpg.45494e16153b95333cd373d2b3afb5ee.jpg

6900K, 128gb ram, RTX 2080ti, R21,  denoise yes.. but I don't care about turning it off, as my purpose wasn't to make the best image (it was a quickie after all) It was to check if prorender is slow or not. It isn't. Cycles is faster.. that's true, but when you get decent results in the 2min range.. it becomes less of an issue. Edit: removed nonsensical chatter.. not a topic worth my time anyway.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...