Jump to content
Sign in to follow this  
FrankDeFrank

Geometry is breaking reflections

Recommended Posts

Hello,

 

 Why is the geometry breaking reflections, when the surface is smooth?

 

The geometry is a bit messy.  

How can I fix it?

 

See attached.

 

Thanks. 

Geometry Problem.jpg

Bubbles_2000x2000.jpg

Share this post


Link to post

Hi 

It certainly is a mess for sure, however id need to see at least the file or part of the file.  It could be a unwelded seam, the normals reversed, Zfighting, or bad Uvs, even the phong angle o lack of one.  Or it could be down to just a very bad triangulated mesh.

 

Dan

Share this post


Link to post
8 hours ago, FrankDeFrank said:

The geometry is a bit messy.  

How can I fix it?

Wow. Fixing that is most likely to require starting that section again IMO, or at least some form of complete retopology. Can't remember a time I saw a more appalling mesh ! 

 

CBR

Share this post


Link to post

Yes this is a good example of how not to do it. Before downloading a model allays check the mesh wire-frame image first, if there is no image reference to the wire-frame  then steer away from it.

This is a good example of mesh:

Koenigsegg_28_3840.jpg

Share this post


Link to post
  • Topic Author
  • Author of the topic Posted

    Thanks guys.

    This is straight from a cad fie.

    I can't change it.  Works well on Maya but not C4D.

    I wish i had the time to re topo the entire thing.

    Need to use c4d.

     

    Share this post


    Link to post

    Triangles+curved surface+SDS=artefacts. The only solution is to retopo. 

    Or maybe try a volume builder+mesher at very high settings. If you don’t need a close up shot this might do the trick. 

    Share this post


    Link to post

    What renderer are you using? 
    Is it an unbiased one (i.e. Octane/Cycles4D)? 

    Share this post


    Link to post

    If its a still and no further angles needed he may have to revert to a quick n dirty way to get around it, retopo the panels that are seen that are problematic.

    Share this post


    Link to post

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    Sign in to follow this  

    ×
    ×
    • Create New...

    IMPORTANT INFO:

    We are in the progress of finalising upgrade to Cafe 3.0. If you are experiencing issues, please change the default theme to Cafe 2.5 and thing’s should work again. We will notify everyone when we resolve all the issues.
     

    It would be also great if you could report any issue you might have on your side so we can fix them. :cowboypistol: