Jump to content
Sign in to follow this  
cinomadic

R21: UV Transform & Move Tools Very Slow

Recommended Posts

Hi,

I downloaded R21 today to try out the new UV Editor enhancements in R21. When I tried using the UV Transform Tool and Move Tool, I experienced very long lag.

 

I also was unable to double-click the UV faces/points to Select Connected. Here's a screen capture:

 

 

My system is:

Windows 10 Pro

Processor: Intel(R) Xeon(R) CPU E5-2680 0 @ 2.70GHz, 2701 Mhz, 8 Core(s), 16 Logical Processor(s)

RAM: 64GB

GPU: 4x NVIDIA GeForce GTX TITAN Black

 

Any ideas what's going wrong? Thank you!

Share this post


Link to post
Share on other sites

Hi, would you be able to upload a scene file? Its hard to tell like this, thanks!


| MAXON Quality Assurance | 3D Artist | C4D Cafe Manager | Gamer in Heart/PS4 ID: SIgor420 |:compEnjoy:

Share this post


Link to post
Share on other sites
  • Topic Author
  • 8 hours ago, Igor said:

    Hi, would you be able to upload a scene file? Its hard to tell like this, thanks!

    Sure and thanks for the reply. I didn't know if it had anything to do with my scene assets, so I uploaded them too. Sorry it's such a big file (300MB).

    R21 Scene

     

    I did notice that a lot of the lag was because my Skin Deformer was enabled. When I disabled it, it was more responsive, however, the move/transform would stop or become erratic after dragging a UV Point around a bit. I also still cannot get consistent results when double-clicking a UV Polygon for "Select Connected."

     

    Finally, I experienced a crash when reorganizing my hierarchy after using the BP UV Editor.

    Share this post


    Link to post
    Share on other sites

    Ok, finnaly had time to invastigate and this is what I have found!

     

    The biggest issue in this scene is a Display Tag on the Bird object you are trying to edit. If you delete Display Tag, its gonna work smothly. Now real question is, why would Display Tag do such thing...Ill keep you updated as soon as I found out. I reported this and we will look into this, thanks for reporting! 🙂


    | MAXON Quality Assurance | 3D Artist | C4D Cafe Manager | Gamer in Heart/PS4 ID: SIgor420 |:compEnjoy:

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • 9 hours ago, Igor said:

    Ok, finnaly had time to invastigate and this is what I have found!

     

    The biggest issue in this scene is a Display Tag on the Bird object you are trying to edit. If you delete Display Tag, its gonna work smothly. Now real question is, why would Display Tag do such thing...Ill keep you updated as soon as I found out. I reported this and we will look into this, thanks for reporting! 🙂

     

    I'm glad you found the major issue. I am eager to hear what you find about the Display Tag.

     

    Thank you @Igor!

    Share this post


    Link to post
    Share on other sites

    Question is, did it helped your scene to work better in UV Texture Editor? 


    | MAXON Quality Assurance | 3D Artist | C4D Cafe Manager | Gamer in Heart/PS4 ID: SIgor420 |:compEnjoy:

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • 21 minutes ago, Igor said:

    Question is, did it helped your scene to work better in UV Texture Editor? 

    It did!

     

    Here's another clue for the UV Editor slowdown:

    • The Display Tag has Ghosting Enabled. I emptied the Cache and the UV Texture Editor performance was much better.

    Share this post


    Link to post
    Share on other sites

    Ha, awesome catch...that is gonna help for sure to narrow down the issue! 🖖


    | MAXON Quality Assurance | 3D Artist | C4D Cafe Manager | Gamer in Heart/PS4 ID: SIgor420 |:compEnjoy:

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • I heard that UV Snapping was implemented in the Editor in R21. Do you know how to get this working? I can create a separate thread if that would be better.

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • I found the Snapping settings in the Move/Scale/Rotate tools.

    Move.thumb.png.4630174e614e1412e6d9572c81a5afc9.png

     

    I am curious: Why is Snapping unavailable for the UV Transform Tool?

    Share this post


    Link to post
    Share on other sites

    Here:

    Screenshot 2019-09-13 at 00.35.37.png----->Screenshot 2019-09-13 at 00.36.50.png

    Unfortunately due to some limitations, it had to be like this at the moment!

     


    | MAXON Quality Assurance | 3D Artist | C4D Cafe Manager | Gamer in Heart/PS4 ID: SIgor420 |:compEnjoy:

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Thank you, @Igor!

    Share this post


    Link to post
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    Latest Topics

    Latest Comments

    ×
    ×
    • Create New...