Jump to content

Sign in to follow this  
IvyBarringer

Half my objects don't show in viewport

Recommended Posts

I have a scene in C4D R21, it's not massively heavy, but there is a fair bit going on. I animated some objetcs in a separate project, then copied them in, and all of a sudden half of my scene doesn't show up in the viewport.  The objects that are missing are completely random too, parts of nested comps, random booles, clones etc.

I restarted C4D and my Mac and they're still missing, if I render they show up fine (including the interactive render region)

 

Also, if I open the project in the R20 demo it works fine, in the viewport and render. I've attached the viewport in R20 and R21.

 

As I say, the scene isn't particularly heavy (15mb), and is working fine in the R20 demo. It's now impossible to animate, as I can't see half my scene

 

R20 Demo.jpg

R21.jpg

Share this post


Link to post
Share on other sites

Pls dropbox the scene and link it here. Almost impossible to give a definitive answer without that.

 

CBR

Share this post


Link to post
Share on other sites

What are your graphics card specs? Could be that you have too many generators, like booles, cloners, or sweeps, that are generating too much geometry for the viewport to display at one time when you add in the extra objects.

 

Avoid making Booles using Cloners, or any generator objects for that matter, to cut another object. If you need to do this, collapse the generator first and Connect + Delete all of the clones into one object before adding to a Boole.

 

Mesh density plays a big part with generators as well, so be careful not to generate geo with more density/sub-divisions than you need. And consider collapsing generators to geo to give the viewport computational breathing room, so to speak.

Share this post


Link to post
Share on other sites

...maybe generators off? Don´t expect kind of viewport clipping since also missing objects in the background...

Share this post


Link to post
Share on other sites
  • Topic Author
  • This helps. It's objects that have something done to them (cloth, cloner, bend, boole etc) that are vanishing. Strange that it still shows fine in R20 though.

    With a lot of the Booles I have them animating up to reveal objects, so I would have to keep these as Booles, I'll sort whatever I can

     

    My specs are

     

    2019 iMac

    Processor 3.1 GHz Intel Core i5

    Graphics card: Radeon Pro 575X 4 GB

    Share this post


    Link to post
    Share on other sites

    Modes/Execution/Use Generators was off?

    (since this command has not assigned shortcut by default,so it can not happend accidentally by pressing some key on keyboard...)

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • @Bezo, I'm not sure what that means?

     

    I'm having the same issue in a brand new project now, if I create a cube in a completely new/empty scene it is invisible unless I make it editable. It can't be because of the that scene. 

    I am on the month version of C4D21 by the way, it expires in 7 days

     

     

    Share this post


    Link to post
    Share on other sites

    If you can, post here scene example with this behaviour. I´m not at my PC currently but maybe some other users will check your scene.

    I´ ll be at home at late night, I can look into your scene if nobody check it. And at the end, if your example scene will be OK for other users, it will be good to ask directly on MAXON support.

    Share this post


    Link to post
    Share on other sites
    1 hour ago, IvyBarringer said:

    I'm having the same issue in a brand new project now, if I create a cube in a completely new/empty scene it is invisible unless I make it editable.

    OK, that's a big clue...

     

    Did you check that Generators are not filtered (see viewport / filter menu), and that Generators are enabled under Mode / Execution Menu as @bezo suggested ?

     

    CBR

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • @bezo and @Cerbera, thanks so much!!!

    That's amazing! I'm not sure how, but generators was unchecked under filter. I never even knew that existed, but certainly won't forget it.

     

    Really appreciate it guys, thanks again. Hopefully this will help someone else in the future

    Share this post


    Link to post
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    Latest Topics

    Latest Comments

    ×
    ×
    • Create New...