Jump to content
Sign in to follow this  
hammondchips

Terrible viewport FPS

Recommended Posts

Hi

I have a medium weight scene which really lags on my PC (decent i7 6800 processor + 2 x 1080ti's) - it drags along at about 4FPS

The same scene on a 7 year old imac gets 15+ FPS.

The Pc renders well, clearly using both GPUs.

 

Any ideas anyone? I've tried playing with the Open GL tickbox, but that doesn't change anything...

 

Suggestions?

Thanks

Alex

 

 

Share this post


Link to post
Share on other sites

Hi,

 

Need more info about your scene, can you attach scene screenshot?

Or upload scene, I can test it on 7820X 4.4 GHz + GTX 1080

 

Dane

Share this post


Link to post
Share on other sites

I get this sometimes too. Difficult to isolate the problem. Sometimes I find that another program running in the background causes a slowdown in Cinema, but sometimes it can be caused by generator elements in your scene, especially if there are a lot of them. Unfortunately having immense graphics cards doesn't make you immune to this. You can usually get a speed up if you use the Level of Detail controls, or (worst case) you can disable the generators on things you are not immediately working on.

 

CBR

Share this post


Link to post
Share on other sites

Something I separate my scene into sections I can turn on and off. I might have the characters and the floor in one, the backdrop in another etc. This way I can work with more detail on the part I am animating at the moment. You have to remember to make those elements visible angle again for the render I forget sometimes and it's super annoying! 

Share this post


Link to post
Share on other sites
  • Topic Author
  • Hi @CApruzzese, @Cerbera @danijelk

    Thanks for your comments.

    The scene is heavy, lots of particles via a fracture object with lots of deformers etc. There is no doubt that the scene and effect could be build more efficiently, the job is now done and so if I had time i should try rebuilding it, but to be honest that's unlikely to happen.

     

    Today i'm on my 13inch MBP with the same file, which still gets a useable 10fps. Without wanting to get involved in a PC v MAC debate, I can't help feeling something on the PC just isn't working right? MAXON drew a blank and all other pointers suggest the PC is running well?

     

    Incase anyone fancies it the file it here, it's 400mb+ so please don't feel obliged, but it you fancy can you tell me what FPS you are getting? I've stripped out all materials but it was setup for Redshift

    Thanks

    Alex

    https://www.dropbox.com/s/fpgqc8qxhluv0d7/Lag Scene.c4d?dl=0

     

    Share this post


    Link to post
    Share on other sites

    Hi,

     

    I just tried your scene, and fps on my 7820X 4.4 GHz, GTX 1080 G1 , KHX 3000 CL15 ddr4, Samsung 970 Pro, Cinema4D Studio R19.068 , is around 18 fps at the beginning, ~15-16 fps at the middle of animation, and ~25+ fps at end.

     

    Dane

    Share this post


    Link to post
    Share on other sites
    On 10/5/2019 at 1:10 PM, CApruzzese said:

    Something I separate my scene into sections I can turn on and off. I might have the characters and the floor in one, the backdrop in another etc. This way I can work with more detail on the part I am animating at the moment. You have to remember to make those elements visible angle again for the render I forget sometimes and it's super annoying! 

    I also often divide the stage into sections. I mainly use layers where you can easily turn on or off visibility, animation, rendering.
    Using layers also gives you the option to exclude elements only from the viewport and leaving active for rendering. I recommend managing the stage like this, and you won't have to be nervous anymore for forgetting to include something in rendering. 🙂

    Share this post


    Link to post
    Share on other sites
    On 10/9/2019 at 2:55 AM, Arte said:

    I also often divide the stage into sections. I mainly use layers where you can easily turn on or off visibility, animation, rendering.
    Using layers also gives you the option to exclude elements only from the viewport and leaving active for rendering. I recommend managing the stage like this, and you won't have to be nervous anymore for forgetting to include something in rendering. 🙂

    Very good advice. taking the time to set things up really does pay off in the end! 

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • @danijelk

    Thanks - That's pretty smooth, but your computer is beefier than mine... 

    @Arte

    I'll look into layers, see if that help

     

    Thanks Cafe

    Share this post


    Link to post
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×
    ×
    • Create New...