Jump to content
Sign in to follow this  
Karl Kaplan

Bump maps on spline wraps are wrong

Recommended Posts

Hi folks,

I am having issues with getting some textures to apply correctly to objects on a spline wrap, even when the splines are converted to geometry (I've included both).

In the attached example, there is a wooden texture and a heavily dented plasticky texture. Despite both having bump maps enabled, they are super smooth on their models. They look awful. Why is this?

 

Thanks!

AlignTex.c4d

Share this post


Link to post
Share on other sites

I must admit the bumb map seems to be working on the editable mesh as expected. You could try a normal map and see if it looks better?

Share this post


Link to post
Share on other sites
  • Topic Author
  • Hm. This is what it looks like on my end, and what the material is supposed to be.

    end cap.PNG

    bump prev.PNG

    Share this post


    Link to post
    Share on other sites

    The texture is set to UV, which may not work that well on this model. It might be better to use a cubic mapping then scale it down in texture mode.  Also you have Luminance on which might be flattering the colour a bit.

    Bump mapping is a kind of 'fake effect' to get a quick texture. Try a normal map., (the purple style textures.) There is a free normal filter in photoshop. The one you are using looks like a parametric texture, which won't work that well if you have a UV texture set. Unless you are going to actually build a proper UV texture by unwrapping the model and paint on it in photoshop, i'd stick to basic mappings like cubic or flat.

    Share this post


    Link to post
    Share on other sites

    Sorry @joolsd that's not great advice. Indeed the converse is true; ONLY UV mapping will work with these shapes. However OP has neglated to do any V-scaling in the texture tags, so the texture is stretched out on the V direction to the point where it can't work. Simply increase the  v-tiling to something like 10 in the tag, and it will be fine. However you are also not looking at noises correctly in the viewport because you don't have that turned on in the Viewport OpenGL options.

     

    CBR

     

     

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • @Cerbera The pixel stretching was definitely the V-scaling. However, I do have noise enabled in the viewport. It's only smooth when I render view (attached).

    noise viewport.PNG

    noise render.PNG

    Share this post


    Link to post
    Share on other sites

    Change the Noise Mode to UV / 2D is the next thing to try...

     

    CBR

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • 55 minutes ago, Cerbera said:

    Change the Noise Mode to UV / 2D is the next thing to try...

     

    CBR

    Bingo. Thanks!

    Share this post


    Link to post
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×
    ×
    • Create New...