Jump to content

Sign in to follow this  
jericsynrgy

noob SubD issue

Recommended Posts

GAH!  This simple mesh is opening up at the poles when SubD'd.  Something simple is wrong, but I can't spot what it is.  I know triangles are nonoptimal, but it shouldn't open up like this.  The mesh has been (auto) "optimized", there's only one point at the poles.

I almost got a solution, but the closed subd mesh was not symmetrical -- the poles were askew.

Take a look, thanks!

subd issue.png

SubD error.c4d

Share this post


Link to post
Share on other sites

Your mesh is not properly connected. Just go to Point mode, select all Points and execute Optimize command. 🙂


| MAXON Quality Assurance Specialist | 3D Asset Creatior | C4D Cafe Manager | Gamer in Heart | :compEnjoy:

Share this post


Link to post
Share on other sites

Actually, he's got a point there (pun intended), but it's in the wrong place !. Selecting all points and optimizing does give an incorrect result, even in R21 Beta builds...

 

Check out where the center point at the top goes here !

 

299386878_Optimizeerror.thumb.jpg.620f967f69daed78ebe5a0fe579ca311.jpg

 

To get what OP wants he needs to select the 8 points at the top and optimize those, then repeat for the bottom, then repeat with all vertices selected.

I'm calling that a bug but there's the workaround...

 

CBR

Share this post


Link to post
Share on other sites
  • Topic Author
  • Wow, that is a whole lot of "optimizing"!   WTHeck?

    When I selected points manually, I didn't find any duplicatessssss....oh.  ----"Only Select Visible Elements", damn you, you foil me again!

    Well, at least I was on the right track (My assumption was there was SOME duplicates in there.).   I also assumed that Optimize didn't require explicit Selection, since it clears out unselected floating orphan points just fine.

    I wouldn't have been in this pickle, Cerebrus, if I hadn't capitulated as suggested, cleared out all but one sector, and Duplicated it around.  LEARNING!!!  <-- i h8z it.

    Thanks everybody!  Go claim that bug bounty!  I want R22 to be bug free if I ever get it!  🤣

    Share this post


    Link to post
    Share on other sites
    21 hours ago, Cerbera said:

    Actually, he's got a point there (pun intended), but it's in the wrong place !. Selecting all points and optimizing does give an incorrect result, even in R21 Beta builds...

     

    Check out where the center point at the top goes here !

     

    299386878_Optimizeerror.thumb.jpg.620f967f69daed78ebe5a0fe579ca311.jpg

     

    To get what OP wants he needs to select the 8 points at the top and optimize those, then repeat for the bottom, then repeat with all vertices selected.

    I'm calling that a bug but there's the workaround...

     

    CBR

    Mmmh... I tried that and got the same, and tried it again with optimization at a 0.05 distance instead, and then the point was in the center as it should be...

     

    There are many more points unconnected than just the two poles in the original model. My suspicion is that points along the sides which are optically in the same place are actually farther apart than 0.01 units, and these are not covered by the optimization, which results in leftover disconnected-but-seemingly-identical points, which then create the above shape when SSD'd. I'll check later again, but I fear that the model is not as symmetrical as it seems.

     

     

    Share this post


    Link to post
    Share on other sites
    1 minute ago, Cairyn said:

    Mmmh... I tried that and got the same, and tried it again with optimization at a 0.05 distance instead, and then the point was in the center as it should be...

     

    There are many more points unconnected than just the two poles in the original model. My suspicion is that points along the sides which are optically in the same place are actually farther apart than 0.01 units, and these are not covered by the optimization, which results in leftover disconnected-but-seemingly-identical points, which then create the above shape when SSD'd. I'll check later again, but I fear that the model is not as symmetrical as it seems.

     

     

    If would be great if you could investigate a bit more, it would help us for sure!


    | MAXON Quality Assurance Specialist | 3D Asset Creatior | C4D Cafe Manager | Gamer in Heart | :compEnjoy:

    Share this post


    Link to post
    Share on other sites

    Okay, I had a look at the actual values. First thing, the upper tris and quads are not connected at all with their right and left neighbors (I have moved and scaled two sides to see the connections better). The distances, however, are minimal. Two optically colocated points are no farther apart than 6.14390630018e-07 units, which is far below the value set in the Optimize dialog.

    image.thumb.png.0335fac344412218a37f0183de90910b.png

    After optimizing with the default values, the side points are correctly merged and form the base of the dome. The tip, which appears off-center, is still two points though. Here I have pulled out one of the two points to show the topological gap:

    image.thumb.png.1eb682986ea1cbff31d36d010d138e6e.png

    So, the subdivision surface is not to blame; it sees two separate areas meeting in a point and its two adjacent edges. The problem is that the optimization doesn't merge all the 8 points of the tip, but obviously creates 2 result points by merging 6 points in one, and 2 points in the other.

     

    Now, why does it do that? In the image above I colored red and blue the two top triangles whose summit points have the greatest distance. But nooo! These two merge fine into the same result point!

     

    To be sure, I looked at the real point positions and the distances between each:

    image.thumb.png.94d4b8382a15f9b5a692a185b816d6ce.png

    The first list contains the 8 selected summit points (index in selection, original point index, position vector). Here, the values are identical (as far as the precision of the vector goes).

    The second list compares each point with each other (two selection indices plus the distance). The last value is the maximum distance of all. Obviously, all the distances, even the maximum, are very very small 6e-7 is 0.0000006 which is far smaller than the 0.01 distance default of the Optimize command...

     

    So I tried optimizing once more, and...

    image.thumb.png.800ae2eb15cca794f81442efee015a06.png

    Everything's fine. What the heck????

    Still sitting and testing here...

     

    Share this post


    Link to post
    Share on other sites

    Sheesh! I just cannot wrap my brain around it. Obviously my first thought was not correct; all the to-be-merged points are easily close enough to each other to be merged.

     

    Final observations: The error happens ONLY if I first select almost all points. Strg-A or dragging a rect selection across the object or using live selection doesn't matter. Once all 144 points are selected, the error happens. If I deselect some points (varying numbers depending on the points), the error does no longer happen - EVEN IF the deselected points have nothing to do with the upper or lower summits!!! I can deselect the outermost points of the petals, which are not even in the polygon loop of either summit, and suddenly the merge shows the desired results.

     

    The error always happens or doesn't happen on both poles at the same time. I have not managed to provoke the optimization to treat the poles differently.

     

    Setting the maximum distance in the Optimization dialog to 0.05 removes the error altogether. 0.04 doesn't suffice. But as my last post showed, that is far, FAR away from the actual distance of the points I expect to merge.

     

    I couldn't find any invisible points that may disrupt the algorithm. Mesh checking does not reveal anything new about that mesh.

     

    So, all in all, the fault must be with the Optimize command that just misses two merges under the described circumstances. Sorry, I have neither an explanation for that, nor a solution except to select less points (so the command works) and always to test the results for an optimization with Mesh Checking. I recommend sending this model in with an error description, as I cannot find reason for this happening except a bug.

    Share this post


    Link to post
    Share on other sites

    Thank you Cairyn, that was interesting to read. Ill pass this information to my team...much appriciated! 🖖


    | MAXON Quality Assurance Specialist | 3D Asset Creatior | C4D Cafe Manager | Gamer in Heart | :compEnjoy:

    Share this post


    Link to post
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×
    ×
    • Create New...